1

I tried booting my mid 2012 mac (which is running Sierra 10.12.6) in recovery mode and opening the terminal; I would like to disable SIP. As per usual, I typed "csrutil disable", and 'command not found' was returned. I looked at klanomath's answer here (csrutil: command not found) though I didn't quite understand what he/she meant by 'booting to your main volume'. I am not sure if that is relevant here, but I am inquiring if there is any further way to disable SIP. Is high-sierra needed or helpful here?

(Also, if possible, an answer comprehensible by someone with very little background in computing or working with the terminal would be highly appreciated)

Thanks in advance.

  • What is your bigger goal? (e.g. Why do you want to disable SIP?) Also, do you have more than one startup volume? – benwiggy Jan 11 at 7:48
  • (1) I am disabling SIP since I there are two packages I would like to run that require SIP to be disabled (specifically: I am running the Dolphin emulator and the Mac is not recognizing a GameCube-to-USB adapter, thus after some googling I found I needed to download a driver to do this and to run this I need SIP disabled). – LinearOperator32 Jan 11 at 7:51
  • (2) Excuse the elementary question, but how do I check if I have more than one startup volume/what is a startup volume in a nutshell? – LinearOperator32 Jan 11 at 7:54
  • A startup volume is a disk that contains a valid OS from which you can boot. – benwiggy Jan 11 at 7:58
1

Instead of just writing "csrutil", replace that with:

/Volumes/Macintosh\ HD/usr/bin/csrutil

so the whole thing becomes:

/Volumes/Macintosh\ HD/usr/bin/csrutil disable

Note that "Macintosh HD" should be replaced with the name of your startup disk. If you do not know the name, then run the following command:

ls /Volumes

It will list the available volumes for you.

If the above gives the error message: "Operation not supported" it means that your recovery system is a version so old that it hasn't got support for the functionality necessary to run csrutil.

In that case try starting up in Internet Recovery mode by holding down Cmd-Opt-R while booting the Mac, which means that the files for the recovery system are downloaded adhoc from Apple's servers. This should give you a version new enough to run csrutil.

In case that is not possible then you could instead upgrade your own recovery partition to a newer version or alternatively create a recovery partition on a USB pen-drive and boot on that. How to do both is described here:

https://superuser.com/questions/1024493/updating-recovery-partition-in-os-x-el-capitan

  • I typed in ls /Volumes, and the message “.Trashes Mac OS X Base System Macintosh HD” was returned. I figured this meant that the name of the startup disc was “Macintosh HD”. However when I typed in “/Volumes/Macintosh HD/usr/bin/csrutil disable”, the message “/Volumes/Macintosh: No such file or directory” was returned. Is there any way to fix this? (All of this was done in the recovery mode terminal) – LinearOperator32 Jan 12 at 2:15
  • I read the edit, and I also tried “/Volumes/Macintosh\ HD/usr/bin/csrutil disable”, but I received the message “/Volumes/Macintosh HD/usr/bin/csrutil: Operation not supported”. Is there something else I’m missing? – LinearOperator32 Jan 12 at 3:17
  • You seem to have started on a recovery volume that has too old software - i.e. before the system supported SIP. You’ll need to update it first - or start from a newer recovery volume on an external drive! – jksoegaard Jan 12 at 7:44
  • How would I update the recovery volume? I have installed all the updates that appear in the app store. Is there another place I should look for the updates? – LinearOperator32 Jan 12 at 18:56
  • @LinearOperator32 I have updated the answer with details. Mainly try first by booting into Internet Recovery mode, if that fails update the recovery partition using the listed link, or create a bootable USB pendrive with a new recovery partition on. – jksoegaard Jan 13 at 8:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .