0

I'm using MacBook Air running MacOS Sierra and using an IP address(provided by my college) that has been bound to my device's MAC address manually.

ie- My device's MAC address is has been bonded with a specific IP address provided by the College's network administrators.

So, I've manually configured the network connection with that specific IP address.

Here is the configuration

Now, when I connect to my phone's wi-fi (Redmi 4A), it gets connected (DHCP), the internet works well and after 2-3 minutes the internet finally disconnects even though I'm still connected to my phone's wi-fi.

Is this due to the manual network settings set only for the IP address provided by the college.

EDIT: :

I found that the manual setting for the college wifi is causing a problem. When connecting to phone's wifi, the Using DHCP option doesn't get automatically selected.

So, what I did is that when connecting to my phone's wifi, I selected the Using DHCP and it worked well.

But the problem now is that when I reconnect to my college wifi, the Configure IPv4 now shows Using DHCP which I had previously selected when connecting to my phone's wifi. Hence, when connecting to the college wifi, all the manual settings have disappeared and I have to fill the configuration details again.

Please suggest some workaround to deal with the above problem. I don't want to reconfigure all the manual settings again and again when I switch between the 2 wifis.

  • What are your TCP/IP settings for your Wi-Fi card? DNS, proxy, DHCP etc? – TimD Jan 11 at 6:35
  • Didn't get you. But, I think I've put up the image with all the configured settings. – Ajay Singh Negi Jan 11 at 7:03
  • Try configuring IPv4 automatically using DHCP. Is there a reason you need to configure it manually? Are there any IPs listed in the DNS tab? – TimD Jan 11 at 7:17
  • @TimD It works well when I select DHCP instead of manual mode(when connecting to phone) but all the configured manual settings get disappeared and when I've to reconnect to the college wifi then I have to manually configure it again. – Ajay Singh Negi Jan 11 at 7:31
  • @TimD Hope that the edit helps now narrow down the solution to deal with the problem. – Ajay Singh Negi Jan 11 at 7:48
2

To connect to your phones hotspot you will need to set Configure IPv4 to Use DHCP.

To have different network settings for the same interface you can set up network locations. For instance, add a new location for college with the IPv4 settings you've specified, and when you're using your phones hotspot or somewhere that doesn't require manual setup, use the default Automatic location.

  • You gave the answer first, so I accepted yours. – Ajay Singh Negi Jan 11 at 16:45
1

You have (at least) two different network configurations, here one for your college on Wi-Fi with a manual IP address, another one through your phone Wi-Fi with a DHCP attributed IP address. You can't achieve this with the default Automatic "Location" (this is the vocabulary of Apple, because a network configuration is often associated with a physical location, but the term is misleading, in fact we are dealing here with a "network configuration").

You will have to create 2 different "locations":

  1. One named College or better College / Wi-Fi with the manual IP configuration provided by your college,
  2. One named My phone or better My phone / Wi-Fi with the dynamical attribution of your IP address with DHCP.

Once you have created the second network configuration a new menu entry will appear within your  menu: Location with a sub-menu which will let you switch from one network configuration to the other.

I even advise to suppress the Automatic network configuration (or location if you prefer to stick to the Apple vocabulary) because it is making too many things magically and when one needs to trouble shoot network problems, the magical features are a real nightmare.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.