20

I can't browse to any website using Safari; yet, Google Chrome and Firefox are working fine. The Mac App Store also reports that it cannot connect.

I am running OSX 10.7.2 on a 2011 MacBook Pro.

7
  • have you tried Firefox too? at least to have a third opinion and see if your WebKit (overridden by Chrome) is having a problem. Dec 28, 2011 at 11:06
  • Firefox also works. Also just checked and it looks like iTunes is unable to connect also. Dec 28, 2011 at 11:16
  • 3
    Do you have anything in your Proxies? (Safari -> Preferences -> Advanced -> Proxies (Change Settings).? Dec 28, 2011 at 11:18
  • Autodiscover was ticked. I unticked and voila! Newish to this site but do you want to post the solution so i can flag as the as the answer? Thank you Dec 28, 2011 at 11:20
  • done, glad to hear you fixed it. Dec 28, 2011 at 11:28

1 Answer 1

18

As we have found the solution using Comments, here's the formal response.

Whenever you experience issues with Safari, App Store, iTunes and any other service that uses the "same" WebKit, but seem to see no problem in Google Chrome or Firefox, it's good to check if you have your Proxies configuration clear. Since sometimes Chrome (and Firefox) override these settings (for their own multi platform stuff), they may work while the formers fail.

This is easily checked by opening Safari -> Preferences -> Advanced -> Proxies (Change Settings).

Make sure Autodiscover is not checked. It should probably look all empty like this:

enter image description here

note/off-topic: the Use PASV FTP is usually a good idea if you are behind a router/modem/NAT like Airport Extreme or AirportExpress (or any other to be honest), since FTP was not designed to be used behind these "hacks". In any case, if you don't know what it is, you can safely ignore it, but if you have FTP problems every now and then (or FTP is slow as hell), check that and try again.

The local ignores for proxies was added by the Operating System, but it's usually a good idea to have your local stuff ignore the proxy. ;)

3
  • 1
    Thanks for that, Martin! My Chrome & FF & Opera all worked fine but my Safari says that my MB wasn't connected to the internet. Your tip got my Safari working again! I'da never guessed it, because that had always been checked before, in all my Mac OS's (currently, I'm running Yosemite).
    – user91346
    Sep 20, 2014 at 1:01
  • This doesn't solve my problem. I'm running 10.12.2
    – Kasra
    Nov 19, 2016 at 16:48
  • Awesome.. worked Perfectly
    – Gags
    Sep 30, 2017 at 5:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .