1

Can't understand why I get this response when running this bless command, can someone please explain or suggest how to fix. Note: the volume syntax/path was copied exactly from the output after dragging location from the volume root folder into the Terminal window:

Last login: Thu Jan 10 10:27:52 on ttys000
xxxx:~ xxxx$ su - xxxxx
Password:
xxxx:~ xxxx$ sudo bless --file /Volumes/ML2/System/Library/CoreServices/boot.efi
Password:
No volume specified
xxxx:~ xxxxx$ 
1

The bless command has be deprecated. Basically, the command is not compatible with APFS. Other replacements are:

  • The systemsetup command. Use options -setstartupdisk, -getstartupdisk and liststartupdisks.
  • The Mac Startup Manager. Basically hold down the option key at startup. To make an OS the default, hold down the control key before selecting.
  • The Startup Disk pane in the System Preferences application.
  • The third party rEFInd Boot Manager. This can be installed without disabling SIP.

However, I you still want to use the bless command, then syntax is shown below.

sudo bless --device /dev/disk0sX --setBoot

Where positive integer X can be found by entering the command given below.

mount | grep "/Volumes/ML2 "

I tested this command by boot to Yosemite on a 2007 iMac. I used the bless command to select El Capitan as the default operating system to boot.

Note: Yosemite does not use System Integrity Protection (SIP)

If selecting a BIOS booting Windows (or other) operating system, be sure to include the following option.

--legacy

Below is the result when trying to use the bless command from High Sierra with SIP enabled. The machine is a 2011 iMac.

Marlin:~ davidanderson$ sudo bless --device /dev/disk0s6 --setboot
Could not set boot device property: 0xe00002bc

Below is the result when trying to use the bless command from El Capitan with SIP enabled. The machine is a 2007 iMac.

Steelhead:~ davidanderson$ sudo bless --device /dev/disk0s5 --setboot
Could not set boot device property: 0xe00002bc
  • Thanks, know how to get into boot manager, but the issue is missing blessed system file on a 10.8. Am running these commands to the 10.8 target root folder mounted in 10.12. The system file needing blessing is 10.8. Does that change things? – VB23 Jan 10 at 17:05
  • @VB23: This is why OP's need to include the computer model/year and the versions of OS X/macOS. I suppose in your case the bless command could still be used. Although, I would assume 10.8 would appear in the Startup Disk pane of System Preferences. – David Anderson Jan 10 at 17:08
  • OK, so question remains even after running sudo bless --mount /Volumes/ML2 --file /Volumes/ML2/System/Library/CoreServices/boot.efi system file remains unblessed. What else to try? Please see output from sudo bless --info /Volumes/ML2 in my answer/reply above._finderinfo[1]: 749497 => Blessed System File is <missing>_ – VB23 Jan 10 at 17:12
  • @VB23: I believe you need to add -setBoot. – David Anderson Jan 10 at 17:16
  • sudo bless --mount /Volumes/ML2 --file /Volumes/ML2/System/Library/CoreServices/boot.efi -setBoot Password: Could not set boot device property: 0xe00002bc – VB23 Jan 10 at 17:20
0

Bless command usually get invoked with more parameters.

One is --mount to specify the volume. In your case it would be:

sudo bless --mount /Volumes/ML2 --file /Volumes/ML2/System/Library/CoreServices/boot.efi

Other frequently used parameters are:

  • --setBoot
  • --folder
0

Sorry, not an answer, but not getting proper formatting from "add a comment", so using the answer option. Don't know my way around here all that well.

The command you provided, sudo bless --mount /Volumes/ML2 --file /Volumes/ML2/System/Library/CoreServices/boot.efi, ran without objection, however still no system file blessed:

sudo bless --info /Volumes/ML2
finderinfo[0]: 612282 => Blessed System Folder is /Volumes/ML2/System/Library/CoreServices finderinfo[1]: 749497 => Blessed System File is finderinfo[2]: 0 => Open-folder linked list empty finderinfo[3]: 0 => No alternate OS blessed file/folder finderinfo[4]: 0 => Unused field unset finderinfo[5]: 612282 => OS X blessed folder is /Volumes/ML2/System/Library/CoreServices

  • Perhaps a misunderstanding here: --setBoot flag appears to be meant to make a volume the startup disk -- no need to do this from the command line--easily done from sys prefs. Just interested in blessing the boot.efi file--missing in bless info. After I ran the --setBoot command, with SIP disabled, I lost the current startup disk (Have 10.12 and 10.6 on internal partitions --- the ML 10.8 is on a partition on an external drive.) When it lost the 10.12 startup disk, kept booting to the 10.6 (with the external quit.) Had to do a PRAM reset and then restore the startup disk to the original 10.12. – VB23 Jan 10 at 20:31
  • I do not believe what you trying to do is normally done on Mac computers. It may not evenly be possible to do what you are trying to do on a Mac computer. The closest you are going to get would be to install rEFInd. Instead of using the bless command to edit the PRAM, you could edit the refind.conf text file. – David Anderson Jan 11 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .