1

I am trying to set up printers via bash script in Mac OS, using lpadmin with the -m everywhere option to let my CUPS server handle the jobs. This works fine from my Linux machines, however the Mac OS test systems (running OS X 10.13) fail with an error "lpadmin: PPD file could not be created"

The command I tried was lpadmin -p driverless_test -v http:/my-server-hostname:631/printers/HP_something -E -m everywhere

I can't see anything wrong with the syntax, and the backend works from the Linux machines, so no problem there either. I have also tried using sudo as well as activating the root account and becoming root.

0

It's obviously (from the error) having a problem querying the server for the PPD.

As an alternative, you can specify the URL to the generic PostScript PPD:

-m drv:///sample.drv/generic.ppd

Or you can use -m raw, though it's deprecated.

Or if all else fails, leave out the -m flag altogether.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .