1

A mount point /home appeared in my root directory that I cannot get rid of. I suspect it was caused by using Docker for Mac, but I have completely uninstalled Docker for Mac, restarted my system numerous times, and the mount point fails to disappear.

At first I thought it was a regular directory, so I tried calling sudo rm -rf /home yields rm: /home: Resource busy and using sudo lsof +D /home and sudo fuser -c /home both yield empty results. At that point I tried sudo mv /home ~ which gave the error message mv: cannot rename a mount point.

I tried to unmount the volume with diskutil unmount /home which executed successfully, however the mount point is immediately recreated, as evidenced by the logs from diskutil activity:

***Begin monitoring DiskArbitration activity
***DiskAppeared ((no BSD name), DAVolumePath = 'file:///home/', DAVolumeKind = 'autofs', DAVolumeName = '<null>') Time=20190109-08:43:03.9065
***DiskAppeared ((no BSD name), DAVolumePath = 'file:///net/', DAVolumeKind = 'autofs', DAVolumeName = '<null>') Time=20190109-08:43:03.9079
***DiskAppeared ('disk0', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20190109-08:43:03.9081
***DiskAppeared ('disk0s1', DAVolumePath = '<null>', DAVolumeKind = 'msdos', DAVolumeName = 'EFI') Time=20190109-08:43:03.9082
***DiskAppeared ('disk0s2', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20190109-08:43:03.9083
***DiskAppeared ('disk1', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20190109-08:43:03.9084
***DiskAppeared ('disk1s1', DAVolumePath = 'file:///', DAVolumeKind = 'apfs', DAVolumeName = 'Macintosh HD') Time=20190109-08:43:03.9085
***DiskAppeared ('disk1s2', DAVolumePath = '<null>', DAVolumeKind = 'apfs', DAVolumeName = 'Preboot') Time=20190109-08:43:03.9087
***DiskAppeared ('disk1s3', DAVolumePath = '<null>', DAVolumeKind = 'apfs', DAVolumeName = 'Recovery') Time=20190109-08:43:03.9088
***DiskAppeared ('disk1s4', DAVolumePath = 'file:///private/var/vm/', DAVolumeKind = 'apfs', DAVolumeName = 'VM') Time=20190109-08:43:03.9089
***DAIdle (no DADiskRef) Time=20190109-08:43:03.9089
***DiskUnmountApproval ((no BSD name), DAVolumePath = 'file:///home/', DAVolumeKind = 'autofs', DAVolumeName = '<null>') Comment=Approving Time=20190109-08:44:16.5264
***DiskDisappeared ((no BSD name), DAVolumePath = 'file:///home/', DAVolumeKind = 'autofs', DAVolumeName = '<null>') Time=20190109-08:44:16.5385
***DAIdle (no DADiskRef) Time=20190109-08:44:16.5386
***DiskAppeared ((no BSD name), DAVolumePath = 'file:///home/', DAVolumeKind = 'autofs', DAVolumeName = '<null>') Time=20190109-08:44:16.5537
***DAIdle (no DADiskRef) Time=20190109-08:44:16.5537

Any tips on how can I find the process that keeps mounting /home and eliminate it?

Many thanks.

EDIT 1:

Output of calling mount:

$ mount
/dev/disk1s1 on / (apfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
/dev/disk1s4 on /private/var/vm (apfs, local, noexec, journaled, noatime, nobrowse)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, nobrowse)

Content of /etc/auto_master:

$ cat /etc/auto_master
#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
  • Can you add the output of mount and the content of /etc/auto_master? – nohillside Jan 9 at 16:58
  • Hi @nohillside - I added the output of mount and /etc/auto_master to my response in an edit - thanks! – the-jackalope Jan 9 at 17:17
  • 1
    /home is a part of macOS, has nothing to do with Docker. Leave it alone! – user3439894 Jan 9 at 17:29
1

Alright, I did some more digging and it looks like pointing the finger at /home was a red herring. The problem arose when I was trying to run a Docker image and received an error message along the lines of there not being enough disk space available in /home to mount image data.

From this response it's apparent that while /home serves no direct use to the MacOS file system (it's not referenced in the official MacOS filesystem guide), it's used to mount files when MacOS is connected to an NFS filesystem, like the one in the running Docker container. Some order of doing a clean re-install of Docker, re-mounting /home, re-pulling the Docker image, and restarting my laptop seems to have fixed the issue and my container is now running without issues.

For what it's worth, it is possible to permanently unmount /home, and I found a guide for doing so on this StackOverflow post, albeit for a much older MacOS version than mine.

Thanks to those who responded!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .