9

I have a MacBook Pro with touchbar and macOS 10.14.1 I'm using a non apple docking station to which I plugged in an LMP keyboard (Model KB-1243) via USB.

Now I want to use the function keys in IntelliJ as shortcuts without having to press the 'fn' key. So I checked the checkbox 'use F1, F2 etc. keys as standard function keys' but it's not working. I still have to press the fn key. I guess this setting is only for the internal MacBook keyboard, because there it works.

But how can I get it enabled for my external USB-Keyboard?

I just tried it with the Karabiner-Elements, set the function keys to the corresponding function key. But it still doesn't work.

4 Answers 4

16

I had the same issue but found a solution. You can enable/disable the feature by pressing the fn+Esc keys on the LMP keyboard. Apparently it's a feature built in the firmware and can't be adjusted with software. It took me hours to find out...

I tried everything first. I downloaded Fluor, Karabiner, FunctionFlip, nothing worked. Until I found that little leaflet in the box with instructions...

4
  • 1
    True ninja trick!!!! Commented Aug 31, 2020 at 14:57
  • This saved my life! Thanks a million times. Commented Jan 15 at 9:51
  • Also works for "MX Mechanical Wireless Keyboard". Thank you!
    – David
    Commented Jun 13 at 11:12
  • 👍 This just worked for my new Satechi Slim W3 Wired Backlit Keyboard. Commented Jun 17 at 14:56
1

Ok the problem seems to be the LMP keyboard. I tested with an official Mac keyboard and it instantly worked! Very annoying...

0

Just in case somebody needs to know where the fn key on the LMP keyboard is:

(in case the picture is not loading: It is two rows above the left arrow key.) enter image description here

0

On the Microsoft keyboard, I needed to click the function lock key, and then the function keys worked as expected no need to change any macOS settings.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .