2

I received a set of AirPods for the holidays and I'm generally enjoying using them with my 15-inch MacBook Pro (2018), which is running High Sierra (10.13.6).

This MBP only has USB-C ports. Four of them. I'm using an Apple 27-inch Thunderbolt display that has an Apple adapter to convert to the USB-C.

If I'm listening to music - for example on YouTube - the AirPods work just fine. I get audio and it sounds great. When I try to use Google Hangouts with video sourced from the external monitor's camera, the video works just fine but I get no audio with the AirPods. If I disconnect from the external monitor and use a video Hangout sourcing the video from the built-in camera, the AirPods work just fine. If I use the Hangout without audio at all, the AirPods work just fine, too.

Considering this, it seems like there's something breaking whenever I'm getting video from the external monitor.

Is there something about my setup that would prevent the audio from working in this situation?


Other notes:

  • I have a set of wireless headphones that have a USB dongle that I plug into the monitor and this works just fine, too (assuming I remember to turn them on).
  • I've not tried to use the AirPods when connected to the external monitor but using the built-in camera on the MBP.
  • What do you see in System Preferences > Sound > Output when you're not getting audio? – nipponese Jan 9 at 4:31
  • I'm pretty sure it shows the AirPods listed and selected (memory can be a bit wonky and I don't have a way to test it right this second). I'm pretty sure I've tried to switch it to something else and back and it still doesn't work. – Catija Jan 9 at 4:37
1

After weeks of poking at this, I've managed to figure it out.

This actually had nothing to do with the AirPods or the external monitor, rather the problem was that Google Hangouts has its own settings to choose which devices are being used for input/output that overrides the system settings. So, while I was frantically trying to change which device was supplying in/out in the system preferences, Hangouts was happily sitting on the devices it had chosen, ignoring those changes.

Once I realized what was going on, changing the setting manually in Hangouts from my other wireless headphones to the AirPods proves effective every time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .