0

I am having an issue and I have no clue what I should be searching to fix it. Not experienced enough.

I have zsh and probably other things I installed many years ago while making the terminal more my style such as iterm2 and etc. Not sure how to list or find the list of them.

Recently, I utilized CleanMyMac software to delete an app. Can't remember which.

Since, I have been getting the following: enter image description here

It is produced in both iterm2 and the terminal.

Not sure what to search for as it isn't an error. However, I cannot run scripts I usually do. I cannot auto complete with Tabs. Might be more of what I cannot do.

I tried:

  • brew update
  • brew reinstall zsh
  • brew unlink zsh
  • brew link zsh
  • brew doctor

Any suggestions or what should be by next step in figuring out the issue. I am guessing a starter file/script/settings must of been deleted or renamed ?

  • Did you try exec bash to see if your bash shell is working normally? Then exec zsh to come back. Your screenshot looks like your login config file has a problem. – Yoric Jan 8 at 5:24
  • 1
    Check your zsh startup files (.zshrc probably) for errors. – nohillside Jan 8 at 6:20
  • @Yoric it looks normal, I can move around. Tabs auto complete is working. I'll try more tomorrow during a break. – Reza M. Jan 8 at 6:20
  • @nohillside, how to check for errors ? – Reza M. Jan 8 at 6:21
  • Something there is creating the output you see – nohillside Jan 8 at 6:28
2

I used brew to uninstall zsh

brew remove zsh

I installed it again.

brew install zsh

Fixed everything.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .