0

I just migrated to Mojave from El Capitan. I am a extensive user of Terminal application.

But I got a bad surprise in this application: the alt+ and alt+ that move cursor from one word to another do not work anymore.

Expected behaviour (what should happen)

Previously, using alt+ in this state (cursor is symbolised with |) :

one two three four|

Led to :

one two three |four

This works fine in Safari or other applications.

Example (what actually happens)

Using alt+ in this state :

one two three four|

Led to (in Terminal):

one two three fou|r

Terminal configuration

My terminal configuration did not change since Mojave installation (option key is not used as Meta key)

Question

Does anyone have a clue about what to change in my configuration and restore expected behaviour ?

  • I did a fresh install of Mojave and it is the expected behavior as you described it. Not sure what messed up your config. Anyway, is there a reason for not using alt as metakey, then moving with Alt + f and Alt + b? As for myself, i remaped Caps for Esc and use vi-mode, jumping with w and b. – Yoric Jan 7 at 11:27
  • I don't understand because it is the default behaviour since I use Terminal under Lion. As I use a french keyboard, I need alt not to be as metakey (to produce { } [ ] e.g.) – lauhub Jan 7 at 12:11
1

Can you check:

Go to Terminal > Preferences... > Profiles > Keyboard

From this pannel, check those two lines:

Key = Alt+ Action = \033b

Key = Alt+ Action = \033f

enter image description here

They might have gone away so you may create them again, or edit and double check the key, the modifier, and the action associated:

enter image description here


As a workaround, (actually it could even be better, so that you don't need to reach for the arrow keys), you could use Esc+f (jump forward) and Esc+b (jump backward).

And because the Esc key is far to reach, for more convenience, map the Caps key to Esc key with Karabiner Elements.

So that you can jump back and forth with Caps+f and Caps+b.

  • Actually, it was already configured as this in my profiles. But it seems that a bug prevented Terminal to take it into account. Closing all tabs, exiting app and re-running it solved the bug. Thanks for the lead ! – lauhub Jan 7 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .