1

I have a Time Machine sparsebundle from an old Mac that I'd like to get access to, but am having trouble repairing it to a point where I can mount the image.

It was created to back up a machine running Mavericks and Yosemite onto a NAS and worked successfully. It's encrypted and I have the password.

I've tried the following and any help/guidance as to where to go next would be very much appreciated.

MBP-0110:~ root# chflags -R nouchg /Volumes/CaptureOne\ backup/MacBookPro.sparsebundle
MBP-0110:~ root# hdiutil attach -nomount -readwrite -noverify -noautofsck /Volumes/CaptureOne\ backup/MacBookPro.sparsebundle
Enter password to access "MacBookPro.sparsebundle": 
/dev/disk3              GUID_partition_scheme           
/dev/disk3s1            EFI                             
/dev/disk3s2            Apple_HFS                       
MBP-0110:~ root# fsck_hfs -p /dev/disk3s2
   Executing fsck_hfs (version hfs-407.200.4).
** Checking Journaled HFS Plus volume.
** Detected a case-sensitive volume.
   The volume name is Time Machine Backups
** Checking extents overflow file.
** Checking catalog file.
   Incorrect number of thread records
(4, 25363)
** Checking multi-linked files.
** Checking catalog hierarchy.
** Checking extended attributes file.
** Checking multi-linked directories.
   Invalid parent for directory inode (id = 15350659)
   (It should be 19 instead of 18)
   Invalid name for directory inode (id = 15350659)
   (It should be dir_15350659 instead of temp15350659)
   Incorrect number of directory hard links
** The volume Time Machine Backups could not be verified completely.

You must log in to answer this question.

Browse other questions tagged .