2

When instructing Siri to play something on macOS that is not in my music library, it says, for instance, "You don't have anything by [artist] in your music".

I can see that it suggests other sources, including Apple Music.

enter image description here

It does not work on the latest macOS (10.14.2, 2018 MacBook Pro), but it does on iPhone Xs with the same Apple ID and subscription. When I open iTunes, I can see that the subscription is active and I can play content from there.

Is there a setting that enables Apple Music as source for Siri on a Mac?

0

Make sure that you are using the same Apple ID.

From this Apple Support article:

Mac: From the menu bar at the top of your computer screen, choose iTunes > Preferences.

On the General tab, select iCloud Music Library to turn it on. You won’t see an option to turn on iCloud Music Library until you sign up for Apple Music or iTunes Match.

Click OK.

  • Thanks, I've tried it without luck. As far as I can see this only seems to make the local library available to all devices using iCloud. – Double M Jan 7 at 7:45
  • @DoubleM ok... have you tried playing songs without Siri? – TNo Jan 7 at 8:05
  • Yes, I can open up iTunes and browse/play Apple Music just fine. Siri only won't make use of it. It acts like my local library was all there is. – Double M Jan 7 at 11:30
  • how about if you say something like: "play ___ from apple music" – TNo Jan 7 at 13:01
  • same :( "..couldn't find it in your music" – Double M Jan 7 at 13:22
0

After a while, Siri started using Apple Music on the Mac as well.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.