1

I'm experiencing an unusual problem that is affecting many of the apps I use on a regular basis, including (but not limited to): Adobe Illustrator CC 2019, Sublime Text 3, FileZilla, and even Apple's native TextEdit! The sequence of events goes something like this:

  1. An app freezes and I must Force Quit out of it.
  2. I try to re-launch the app, but the icon just bounces in the Dock endlessly (until I Force Quit again)
  3. I try to Shut Down the Mac, but macOS insists it can't shut down because said app is still running (although it shouldn't be, since I did a Force Quit). Also, no dot is shown below the app's Dock icon, leading one to believe it is not open, but it's still running.
  4. I must physically hold the power button to shut down.

^ As you can see, the application is "Not Responding". But there is no dot below to indicate it is even open to begin with.

I have tried to Force Quit the app(s) in question via Terminal as well, after identifying their Process IDs. Unfortunately, this has not worked either.

Further Details

macOS is the most current version to date: Mojave 10.14.2

This iMac shipped with High Sierra and I immediately updated it to Mojave before beginning to use it. This problem came to my attention after less than 1 month of use. I updated Mojave to 10.14.2 hoping it would fix the problem, however the problem persists. The Mac is just over 2 months old.

  • Did this start happening after you updated to the most recent macOS? Try re-updating macOS using the latest Combo Updater. Make a full backup first! – IconDaemon Jan 7 at 1:12
  • @IconDaemon What's the difference between the "Combo Updater" and doing a regular update? Because that updater is for updating to 10.14.2, which I am already using. I don't know of any way to revert to a previous version of Mojave. But more importantly, this problem began before I updated, so I believe it is unlikely that changing versions will remedy it. One thing I did just try is resetting the PRAM and SMC... waiting to see if it helps. – Mentalist Jan 7 at 1:39
  • Have you tried using sudo killall app\ name to kill them? Not sure if it's different than killing it by it's process id – Sam Jan 7 at 2:00
  • You should edit your question to include the information that this problem was occurring before the update to the latest version. How long has it been happening? Since which version of macOS. Another troubleshooting task is to create another user account and see if the problem recurs. If not, the problem lies in your user account. – IconDaemon Jan 7 at 2:03
  • @IconDaemon I have edited my question to include that information. I will also try testing on a new user account. – Mentalist Jan 7 at 4:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.