1

I've got a spreadsheet in Numbers which was a .xlsx file previously. In Windows I used to have one the columns of this spreadsheet to be shown in a Farsi/Persian/Iranian font. This column is only meant to show numbers in Farsi.

When replicating this in Numbers by installing the same font I used in Windows and setting that column to use that font. However, it seems it just changes the numbers to that font, but instead of the numbers being written in Farsi numerals they are shown in the "regular" numerals like 1, 2, 3...

I believe it's possible to just write each cell individually by changing the keyboard to Farsi, but this is an extensive column and I'd like to do this manually.

I can try to provide further details if needed. Thank you!

  • 1
    What is the font you are using? Do you get the same result when you use a standard Apple font like Geeza Pro? – Tom Gewecke Jan 6 at 12:16
  • @TomGewecke I tried using a font called F_titr which was the one I used in Windows. I tried with the Geeza Pro font, but I got the same behaviour. It seems I was wrong and if I change the keyboard to Farsi and write the numbers they will appear in Farsi while typing but will be changed back to latin numeral when I press Enter. From what I could gather it seems Numbers only allows to set the entire spreadsheet to a given language and is not able to mix two languages? I changed the language to Farsi and everything became Farsi. – Sasha Fonseca Jan 6 at 16:01
1

In Numbers go to:

File menu > Advanced > Language and Region

Numbers Menu

Select Persian from the dropdown list for the languages and then hit OK.

Numbers Language Settings

That will revert your numbers as well as the rest of the locale related settings to Persian.

Voila!

Voila!

(You can do the same in Excel or the rest of the Office family).

Update:

Note that this method will change all numbers in your file to Persian. Seems like there's no proper way of having a bilingual sheet; you need at least two sheets one in each language. Also, if you want to retain everything and only apply it to one set of numbers, then, weirdly enough, you need to type any letter in Persian, then input your number. If the global language setting of the file is on English, it'll display the numerals in English, unless you keep at least a Persian letter before the digit in the cell. This is far from ideal, but I can't seem to find another work around this.

  • He wants only one column in Persian and the rest in English. Does your fix allow that? Read his comment of Jan 6. – Tom Gewecke Jul 5 at 12:34
  • @TomGewecke ah, you're right, it doesn't, but I updated the answer to fit better. Nothing super practical really! – Neeku Jul 5 at 13:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .