1

When I try to install mac os high sierra using internet recovery, i get a frozen black screen with an exclamation mark and a error message saying "apple.com/support -3403F". I have tried recovering from multiple locations using different wifi's as well as completely open firewall settings on my home router. My question is, what is causing this, how do i debug it, and how do I fix it?

Thanks!

pic1 pic 2

1

That indicates your machine can’t reach the internet.

Troubleshooting this will be challenging unless you have network / wire shark capabilities and can make sure the packets from this machine are going unhindered to Apple’s servers.

In practice, this is far easier to diagnose by using a second Mac on this network to see if it can boot to recovery. If not - you know it’s the network. If the second can boot - you have a hardware failure or network card failure on the problem Mac.

Taking the suspect Mac to another network that is known to be good (or just taking it to 4 or 5 networks and assuming one of them has to be OK) can also help you isolate if the problem is the network or the hardware.

Lastly, setting up a caching server on your local network would let you see those logs and be sure the Mac in question was requesting the correct recovery image from the internet.

Content caching is a super power move, since you only download one copy of each asset, then your local network accelerates all further installs and boots.

  • Thanks @bmike ! Other macs work on my network and this has been tried on about 7 different home networks as well. Still no dice. I was definitely hacked a while ago most likely a targeted attack by the fbi as I was a suspect for something (i didnt do anything obviously or i would be in jail, haha). My other mac was not affected as I got it after the investigation was dropped. Could that have anything to do with it? Since we know its not the network, and that it doesnt work even if i use an ethernet adapter at boot, is there any other way of fixing this? – DanRan Jan 5 at 21:34
  • @DanRan I would probably want to run the latest Mojave’s installer to ensure all firmware is upgraded. Then erase and go back to an older OS if you want. The new macs with T2 chips will be far more resilient to exploits, but that involves cost. I’ve gotten that error when we were rate limited and when the Apple servers were overloaded. We had a lab with 50 iMacs that got our IP rate limited one day when all of them booted to internet recovery without a local caching server. Sounds like you are pretty sure it’s not a temporary issue, though. – bmike Jan 5 at 21:40
  • Thanks @bmike! I actually have done all of these things, but im still having the same issue. Infact now im having even more issues. It seems like my computer is actually running off an instance of a cloud server as a virtual disk. My partition map is all over the place when checking it with testdisk, gdisk, sgdisk, fdisk, etc etc. furthermore, i am getting constant crc errors on all of my drives as well as any usb tick i plug in. My os is showing random old home directories of mine in the trash can on boot. Im assuming these are old unfrozen apfs containers or shadow copies or something. – DanRan Jan 10 at 0:33
  • Lastly, in testdisk, when searching for mbr's, it is pretty much showing that a new pmbr (or mbr) is created every time i boot. Also, my apfs volume seems to be booting in raw mode. Pretty sure its supposed to be a non writable container correct? Or is that only the recovery partition? Finally, testdisk also shows my hard drive as being the size of every one of my hard drives combined, and when searching for deleted files, i am finding partition maps all over the place marking begin and end sectors of my other drives and usb sticks (even though they are all unplugged). It almost feels like... – DanRan Jan 10 at 0:38
  • It almost feels likeim running a raid array or something. Or my hard drives and partitions are actually virtual disks being run off of an external high speed cloud server from a sattelite or something. Its just very odd whats happening. The more i try to inspect it, the less google tells me and i start getting les and less information in my search results. Its almost as if information about all of my problems are being blacklisted from my search results. Ive also had many instances of results on the terminal changing after i googled something and found an answer to my specific problem. – DanRan Jan 10 at 0:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.