0

I have the above MBA upgraded from the original 128GB Flash Drive to the present OWC AURA SSD, some 2 years ago and it has been working fine with macOS 10.12.6 Sierra. It is also encrypted upon power up before loading the OS for travelling protection. I tried to update to macOS High Sierra but cannot as it says I need a firmware update. I have read before to reinstall the original drive to allow the firmware update, but I no longer have that. What can I do now?

  • Are you sure the drive hardware is the problem? Perhaps your EFI partition is messed up. Can you post the output from the command diskutil list. Also, what model year is your MBA? – David Anderson Jan 5 at 11:23
  • Hello, I can now add to this and complete :) I went to the OWC site and downloaded the firmware updater, (eshop.macsales.com/Service/Knowledgebase/Article/10/730/…) which then allowed me to update from macOS Sierra 10.12 to macOS High Sierra 10.13 so all is now solved :) Thank you for your followup David. – RobertM Jan 6 at 0:08
  • my MBair is a 11" early 2014, forgot to add that in the description ! – RobertM Jan 6 at 0:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.