7

My father has rented a move on iTunes, but on his old computer (which can't cope and crashes when he tries to play it). He's now on a newer computer, and logged into iTunes with the same account, but we can't find the rented movie.

0

5 Answers 5

5

I can confirm that the following works:

  • I downloaded a movie on my pc-laptop
  • I moved it via my network share, added it to the library on my macbook
  • It was visible as rented there but could not be watched (authorized to another computer)
  • Then I unauthorized the computer I downloaded it on and it worked on my macbook
2
  • Yes, this was the only thing that worked for me too.
    – kareman
    Jun 3, 2013 at 18:04
  • +1: I could re-download on different Mac but could not start playback. De-authorizing helped.
    – n1000
    Feb 8, 2015 at 20:23
3

You should move your dad's entire iTunes library from his old computer and merge it with the iTunes library on his new computer.

Read Apple's technical support documentation article: iTunes: How to move your music to a new computer

3

You need to log into the other computers iTunes with the same iTunes username and password. Go to the "store" menu bar item and click "Check for available downloads".

This will bring up movies you have rented with the same account - as long as they are still valid.

2

You can manually copy the movie.

Right-click on the file and select Show in Finder then copy the movie onto a flash drive and move it to the new computer.

When on the new computer - opening the file should open iTunes. Since it's connected to the same account, the movie should play.

enter image description here

3
  • This does not work, it says 'Cannot play because it is authorized to play on another device'
    – fredley
    Dec 27, 2011 at 16:02
  • 3
    Then authorize your computer this way: in iTunes go to: Menubar -> Store -> Authorize this computer
    – gentmatt
    Dec 27, 2011 at 16:11
  • No, it doesn't work that way for rentals. See macworld.com/article/1153224/itunes_movie_rentals.html for details.
    – TJ Luoma
    Jun 2, 2013 at 19:26
1

The computer is already authorised. It appears that it is the 'file' that needs to be authorised to play on another computer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .