0

This question already has an answer here:

I've tried this Silencing "Your disk is almost full" notification

That didn't work.

I've tried deleting "diskspaced" from the disk using sudo, it didn't allow me to delete it.

What's a fool-proof way to silence these bloody notifications?

marked as duplicate by Tetsujin, Allan, user3439894, Nimesh Neema, Glorfindel Jan 4 at 18:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

From this Apple-recommended answer on this discussion:

When that message appears, it should not be ignored. The only way to stop it from appearing is to increase available storage space so that your Mac can continue to work normally.

Cache can take up a lot of space.

To remove cache folders:

Open a Finder window and select Go in the menu bar.

Click on “Go to Folder…”

Type in ~/Library/Caches

Delete the files/folders that are taking up the most space.

Now click on “Go to Folder…”

Type in /Library/Caches (simply lose the ~ symbol)

And, again, delete the folders that take up the most space.

When the message appears you can also click manage and see what options optimise storage offers. This moved unused files to iCloud.

Alternatively, you can check your Mac for unused files or download a file cleaning application.

To find out what is taking up your space go to manage storage.

  • no of that takes up my space – nylypej Jan 4 at 17:12
  • @nylypej To find out what is taking up your space go to manage storage. – Daniil Manokhin Jan 4 at 17:14
  • I'm not asking what it is what's taking space – nylypej Jan 4 at 17:15
  • @nylypej the warning can not disappear unless you free space – Daniil Manokhin Jan 4 at 17:16
  • then your answer is wrong anyway – nylypej Jan 4 at 17:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.