3

As soon as I install the NordVPN app from the app Store on MacOS Mojave, the internet connection dies. I can't use my browser, or any internet connected apps.

Deleting the app and then restarting the computer restores the internet.

With NordVPN installed, there are same symptoms even when I login to my user account in safe mode.

Pinging a website from terminal works fine.

What I have tried:

  1. DNS flush
  2. deleting my WiFi interface and adding it again
  3. trying a different connection (using personal hotspot from my phone)
  4. uninstalling NordVPN and deleting all the leftover files in cache etc. and then reinstalling the app again.
  5. everything works well on a different admin account on the same Mac.
  6. most of the advice I could find on the internet didn't help

I am suspecting that NordVPN is somehow turning on the kill switch as soon as it's installed. To that end, I tried turning the kill switch on and off on the app to rule that out and the internet still didn't work.

How do diagnose this? NordVPN customer service was of no use.

3
  • I started using NordVPN recently have faced the same issue but the other way round. I installed it via Homebrew Cask and observed it. Additionally, I was unable to update the app to a newer version via the app. Removing it and installing from the Mac App Store (older version than available via Homebrew) appears to have resolved the issue so far for me.
    – Nimesh Neema
    Commented Jan 4, 2019 at 18:49
  • Any update? I experienced this today for the first time on an apple router that apparently doesn’t have “vpn support” or “infrastructure”. Nothing short of removing the NordVPN client will allow me to connect to the internet. Any way to whitelist a connection on Mac like on my iPhone?
    – Shakes
    Commented May 27, 2019 at 1:42
  • No Updates. NordVPN asked me to install OpenVPN version from their website and not the IKE one.. that helped for a few days but ultimately stopped working as well. I had to do a clean install of the OS to get it to work again.
    – Anton Unt
    Commented May 29, 2019 at 11:34

2 Answers 2

1

Try this. Open the NordVPN preference and make sure your wifi/network is listed in the Trusted Wi-Fi networks:

enter image description here

1
  • thank you - also what a godawful default setting
    – jlansey
    Commented Nov 30, 2023 at 9:38
0

You can also add to trusted networks in the nordvpn app - easy to miss the wood for the trees on this one

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .