0

The three-button mouse on my iMac is showing some weird behavior:

  1. Clicking once selects something
  2. Clicking twice selects everything
  3. Scroll wheel does a horizontal scroll (instead of vertical)
  4. Vertical scroll must be done by dragging with the mouse
  5. To deselect, I have to use arrow keys
  6. Clicking on a url opens in a new window instead of the same window.

What I have tried so far:

  1. Playing with settings in System Preferences
  2. The mouse is of Logitech brand but is not detected by "Logitech options". I tried a different Logitech mouse with the same result. So it is not a hardware problem because I was able to reproduce it with both mice.
  3. The only remedy I have found is to restart the computer. But within an hour or so, the problem comes back.
  • What OS version? Do you have the latest version of the Logitech Control Center installed? – fsb Jan 2 at 22:01
  • OS X 10.14.2 with Ligitech options (not control center) v 7.10.5 – wander95 Jan 2 at 22:03
  • Installed the control center as well. That detected the mouse. I will test it for a few hours and get back – wander95 Jan 2 at 22:14
  • Have you tried removing the preferences and starting from scratch? See apple.stackexchange.com/a/347002/237687 – Solar Mike Jan 2 at 23:05
  • If Logitech Options can't find the mouse, it's highly likely your mouse is beginning to fail. Try a different mouse (a regular USB one is fine). If the problem goes away, it's your mouse. You can also try booting into Safe Mode to rule out software compatibility issues. – Allan Jan 2 at 23:14

You must log in to answer this question.

Browse other questions tagged .