1

One of my USB drives used to mount fine on my macOS, up until last night when I tried to upgrade from High Sierra to Mojave. During the upgrading, I realized that my drive was still connected, so I unplugged it.

Then after the OS was fully upgraded, Finder no longer mounts the drive automatically when it's plugged in, and in the Disk Utility, though I can see it in the list, it was grayed out. I can't mount it or eject it, either.

In Terminal, diskutil list can see it, but mounting with mount got a time out, so did eject.

It works fine on Windows OS through BootCamp. I even did a disk scan using Windows utility, trying to fix whatever that may have failed macOS, but nothing improved from that. All my other USB drives work fine on both OSes. So it must be something between the specific drive and macOS.

1

I found the solution in another post:

External Hard Drive Won't Mount

ps aux | grep fsck to find the PID where fsck locks the drive.

Then

sudo kill -9 <PID> to kill fsck.

After that, my drive mounted normally.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .