0

In my quest to update my mac pro 2009 (4.1), I did encounter a roadblock, since the last OS that I can run on 4.1 is 10.11.

Now; I found a method to flash the machine so it becomes a 5.1; which allow me to install up to Mojave I believe. The problem is that after following the instructions, the machine won't update. This is what I did

  • mount the firmware update DMG and run the app, it create a ram disk on desktop
  • Once done, it ask me to shut down the computer and restart it.
  • I restart as per instructions; holding the button until the light flash and the machine beep, but it just boot in the current os, and no update is done

I did check the following

  • my 4.1 mac has the latest firmware available officially from Apple
  • I have the original GT120 that came with it, in the bottom slot (not the 16x, since that card is garbage); also the only other devices plugged in, beside the mouse and keyboard are 2 extra hard drives.

So far, after reading forums and tons of huge posts, I found no way to solve my problem. So I hope anyone here has experience with the procedure and can point me to the right solution. Once I get this done, my second step will be to go for High sierra or Mojave, and then try to install windows via bootcamp, but one step at time.

  • One flaw in your plan is that a MacPro5,1 does not support Windows 10 through the use of Boot Camp. Windows 8.1 is the maximum supported just like the MacPro4,1 models. You would need to own at least a MacPro6,1 before Apple would officially support Windows 10. – David Anderson Jan 2 at 3:36
  • I read elsewhere if you first install windows 8.1 you can upgrade to Windows 10. – historystamp Jan 2 at 6:14
  • @DavidAnderson I do understand that "officially" it is not supported; but I am not really that keen to give in to the demands of Apple; considering that I was able to install W10 on old computers without problems. Planned obsolescence is the only reason for Apple to lock installation of OS. Flashing from 4.1 to 5.1 is a way to counter such behaviors; and from the videos I saw online, people were able to install W10 on 4.1 flashed, so while not kosher for Apple; it is worth trying it – rataplan Jan 2 at 7:44
  • @historystamp Correct; you can upgrade but the upgrade often fail. I do not have W8 but W7; and when I tried to upgrade to W10, the windows installer would fail all the time – rataplan Jan 2 at 7:45
1

First, check the requirements:

  • 64bit EFI needed (MacPro 4,1 has it)
  • latest firmware Update (You seem to have this)
  • Do you have enough memory and CPU? (I upgraded my MacPro to 32GB RAM and 2x QuadCore 3.2GHz CPU.)
  • Metal capable GPU like newer nvidia 960/980/1080 GTX?

I am running Sierra 10.12.6 fine on my MacPro 3,1 with latest 1.5 firmware, but I used the installer coming from http://dosdude1.com/software.html, which creates a bootable USB media to install from. That worked like a charm.

So I suggest you try the software from dosdude1 - there is a perfect instruction page how to build the installer from the original Apple Installer and how to use it. (Never ever forget to apply the patches regarding software update provided by the dosdude1 installer!)

I already tried to upgrade to High Sierra and got the feedback from Collin aka dosdude1 that I would need a metal capable GPU, because I got several weird hang ups with my ATI R9 280X during the installation process. Therefore I need to buy a new Nvidia GPU, preferably a 980GTX.

  • Once you have the 4,1>5,1 firmware installed & a Metal GPU, there's no need for any hooky updaters, it just works using Mojave straight from Apple. – Tetsujin Jan 2 at 13:56
  • Just wanted to provide an alternative way - But in the past I had the same troubles with installing the firmware update; I had to release the button for half a second after initial poweron and immediately hold it. Then the firmware update worked. – Garex Jan 2 at 14:38
  • My 4 > 5 was done before I bought it so I've never done it myself [hence can't provide an actual answer] but the extra firmware update to install Mojave I had to wait until after the beep; releasing at the flashing lights didn't work. As I was testing all the way through the beta phase & it demanded to be re-done every single week, I had a lot of practise at timing it ;) – Tetsujin Jan 2 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .