0

I've got an odd ApplePay issue I'm trying to resolve, that I've been struggling with for a few months. I have a 2016 MacBook Pro, with the Touch Bar & TouchID. ApplePay has worked in the past, but sometime after upgrading to Mojave I discovered that ApplePay no longer works from within Safari.

When I'm prompted to approve an ApplePay purchase from within Safari, the transaction never completes. I'm prompted to approve with TouchID, and that's as far as the transaction gets. There is no error, it just sits prompting to approve via TouchID and eventually times out.

The issue appears to be account specific. I found that if I setup ApplePay in a separate test account on my laptop, the transaction does complete as expected.

Another thing I've tried is disabling TouchID for ApplePay. With it disabled, I'm now prompted to enter my account password to approve the transaction, and like before, it just sits and doesn't complete. Again, no error, it just sits prompting me to enter my password, not validating the password when I hit enter.

It's very odd. ApplePay works fine on my other devices, just not on my primary laptop.

What steps should I take next to isolate further what is specific to my login that is causing the issue? Any tips would be appreciated greatly.

You must log in to answer this question.

Browse other questions tagged .