This is my first apple computer (MacBook air 2015). I had to install windows on this because my school wanted it.

I tried installing through bootcamp and it failed the message was "windows support software could not be installed on targeted device" then it said it was removing the partition and for hours nothing happened.

Then again opening bootcamp assistant the message was "The startup disk cannot be partitioned or restored to a single partition"

My original storage was 128GB now it's 84GB, how can I get the rest back?

 $ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         84.0 GB    disk0s2
/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +84.0 GB    disk1
   1:                APFS Volume Macintosh HD            43.5 GB    disk1s1
   2:                APFS Volume Preboot                 44.8 MB    disk1s2
   3:                APFS Volume Recovery                517.0 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
$ diskutil cs list
No CoreStorage logical volume groups found

Also when I open disk utility disk utility schreenshot

  • Which release of Windows 10 were you trying to install? Was it the October 2018 release (1809)? Dec 29 '18 at 21:10
  • Yes sir it was October but after resizing the partition I did it again with same iso and worked pretty well Dec 31 '18 at 1:35
  • I assume then Windows 10 installed and is working correctly. Did you need to use a USB flash drive to install Windows 10? Your answer will allow me to better help other users. Dec 31 '18 at 1:44
  • No sir I did not need a flash drive. ISO file was there in my mac. I just put that into bootcamp Jan 5 '19 at 4:16

The problem was solved after running a command

diskutil apfs resizeContainer disk1 0g

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .