0

I have a virtual machine (VMWARE) with macOs Mojave 10.14 installed. And I tried to open the following icecast link in Safari 12:

http://nashe1.hostingradio.ru/nashespb128.mp3

It's a radio stream. However, Safari doesn't play it. I see only the message: "Unsupported plug-in". But as far as I know it should be played via Html5 audio element, it's mime type is audio/mpeg, and no plug-in is required for it.

The same result I have in a virtual machine for VirtualBox.

However, the problem is that a colleague, who have a mac, tried to open the link, and it works for him well.

Thus, I wonder what may be the problem and how can it be fixed?

  • check and compare your Privacy settings in Safari to you colleague – Ruskes Dec 27 '18 at 18:14
  • Does it work if you access the link on the host running the VMs itself? Can you play audio tracks through iTunes and QuickTime on the VM? – nohillside Dec 27 '18 at 18:20
  • Also please be aware that questions about "Installing or using Apple operating systems on non-Apple hardware" (What topics can I ask about here?) are often considered to be off-topic, especially if the problem can't be reproduced on standard Apple hardware. – nohillside Dec 27 '18 at 18:22
  • @nohillside yes, I can play tracks in iTunes (didn't try QuickTime), after I authorized the computer, and the link above is opened correctly not only on the host machine, but in Google Chrome in the VM too. I even downloaded the Tech Preview of Safari, and the same problem takes place for me in case of the Tech Preview. – RussCoder Dec 28 '18 at 7:27

You must log in to answer this question.

Browse other questions tagged .