1

I have a 2018 15" MacBook Pro running macOS Mojave 10.14.2. I am unable to send emails from any account (be it Yahoo, Hotmail, AOL or others) using any app (tried the default Mail app, Canary Mail, Spark and Airmail). I am, however, able to receive emails without any problems.

Whenever I try to send an email, it ends up Outbox, and I get a prompt to specify outgoing server, which I do for the specific mail servers according to the official requirements on their websites. Most of the times, I cannot even add the outgoing server into the SMTP Server List because after adding it and clicking OK, it doesn't remain therein, it just disappears. Those few times I somehow managed to add an outgoing server into the SMTP Server List, I still was not able to send emails even though in the Connection Doctor the connections all appeared to be OK (green dots).

Now I just checked and the same is happening on my iPhone, I can receive but I cannot send emails. I suspect it may have something to do with iCloud Keychain, which I have enabled but I'm not sure and I haven't tried disabling it so far.

Anyone has had a similar problem and was able to resolve? Any suggestions?

  • 1
    Your ISP (or network admin) is blocking SMTP traffic. This is not an Apple or more broadly, a device issue. It's a networking issue. – Allan Dec 27 '18 at 16:03
  • @Allan Rofl Lmao – yssup Dec 27 '18 at 17:47

You must log in to answer this question.

Browse other questions tagged .