I got a new computer today. I my parents logged in with a username I didn't want so I made another admin. Now, I'm trying to delete the old account.

when I go to Users & Groups in System preferences, click on the old account, hit the - sign to delete it and enter the password, the popup shakes like the password didn't work. I'm sure the password is correct because I used it multiple times to log into the account. I tried switching the old account to admin but that didn't work.

I typed in the password but it didn't work

  • Did you check for Caps Lock and the other usual suspects? Is the user to be deleted still logged in?
    – nohillside
    Dec 25 '18 at 19:15
  • Yes I did check for Caps Lock and the user is not logged in. Dec 25 '18 at 19:18
  • Might try the password from the other account (I.e. whichever one you aren’t using when it hasn’t worked.)
    – dwightk
    Dec 25 '18 at 19:54
  • I tried that too and it didn't work Dec 25 '18 at 20:01
  • Did you try to untick the "reset with AppleID" option and delete afterwards?
    – nohillside
    Dec 25 '18 at 20:36

If you can't delete the user for some reason, you can remove it at the command line.

Launch "Terminal" (from /Applications/Utilities/Terminal.app, or search via Spotlight) and type:

sudo dscl . list /Users

...followed by your administrator password. Then hit enter

The output will show you the shortname of your local users (towards the bottom). Here I called the user to be removed "testy" (I'm only showing the last few entries):


Now remove the user from your system and from System Preferences (exchanging the shortname "testy" with your own, found earlier):

sudo dscl . delete /Users/testy

Then hit enter.

The home folder of that user you can either keep, if there are important files, or delete it with...

sudo rm -r /Users/testy 

...and again hit enter.

PS. A speculative answer for the permissions error received and mentioned in the comments section can be found at StackExchange: What causes eDSPermissionError when running dscl?

  • 3
    It gave me this error: <main> delete status: eDSPermissionError <dscl_cmd> DS Error: -14120 (eDSPermissionError) Dermots-MacBook-Pro:~ "my new account's username"$ Dec 26 '18 at 15:37
  • I'm sure used the name for the old account where you put testy. I tried It a few times and I got the same error. Dec 26 '18 at 15:39
  • It looks to me like an issue with the cryptouser, where I'm most likely in over my head. Does dscl . -list /Users GeneratedUID list the same UID as diskutil apfs listcryptousers disk1s1 (where disk1s1 should be your boot volume on the synthesized disk, as shown in the output of diskutil list)? A search finds a workaround that seems somewhat long-winded and I'm not confident that the problem has been understood properly: medium.com/@ambroselittle/…
    – Redarm
    Dec 26 '18 at 16:36
  • The UID generated from the second command shows up next to my old account's username in the first command. It is exactly the same. Dec 26 '18 at 17:13
  • And how many cryptousers were found (excluding any starting FFFFEEEE...)?
    – Redarm
    Dec 26 '18 at 17:21

The bold text is a misnomer and likely a bug, see the smaller text underneath. The prompt requires an administrator username and password, i.e. your credentials not that of the account you’re trying to delete.

  • The User Name box displays my old account's username. The text is grey and won't let me change the name to my current account. I tried using the password for both accounts again and it didn't work. Dec 25 '18 at 20:35
  • @Dermot Interesting, what’s the Mojave version? I tried with a new test account on Mojave 10.14.2 and it requires my administrator password, how odd. Perhaps an iCloud link is the difference, pure speculation but maybe this is something to do with the account having logged into iCloud which my test account was not?
    – grg
    Dec 25 '18 at 20:43
  • It's Mojave 10.14.2. It's a brand new computer. Dec 25 '18 at 20:44
  • Is there anything else I can try to delete the account Dec 25 '18 at 21:01
  • I still have not been able to fix the issue, do you have any more suggestions. Dec 26 '18 at 2:16

I had this problem and fixed it.

  1. From the Users & Groups panel, right click the user in the list to get Advanced Options...
  2. I Removed the Apple ID and changed the account name (I don't know which did the trick.)
  3. Click OK and restart
  4. Go back to Users & Groups and delete the account with the minus sign box, as usual

This may be a stupid question but did you try typing the password in a text editor to see if you are typing it correctly? Can sometimes be a special symbol issue that is not typed as you think. (for example : \ # @ € $...)


I had this same issue with Mojave and all i did to FIX it was...

  1. Login to the users account that i was trying to delete
  2. Change the pass to something else and log out again.
  3. Go back into the admin account
  4. Remove the account using the new password.
  • I did as you advised, but it does not work for me. Oct 1 '19 at 3:45

For anyone still struggling, here is what solved it for me:

  1. Logged in as a Standard User, ALICE, and gave ALICE Admin privileges (now 2 admins)
  2. Enabled Secure Token for the other Admin Account, BOB with

systemadminctl -adminUser ALICE -adminPassword ALICEPASSWORD -secureTokenOn BOB -password BOBPASSWORD

  1. Logged back in as BOB and was now able to delete ALICE in Users&Groups

The issue seemed to be with the fact that at least one account must have the Secure Token enabled

P.S. sysadminctl interactive -secureTokenStatus ACCOUNT to double-check if Secure token is enabled

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .