3

I have a macbook pro 2015 (8gb ram, running macOS mojave) stuck in the loading screen with the apple logo and the loading bar 100% completed.

  • I tried leaving it for long periods of time.
  • Resetting the PRAM and SMC didn't help.
  • The machine wont go into safe mode using the shift button.
  • It also won't go into recovery mode using command+R.
  • Internet recovery also does not work either. After the globe finishes loading in internet recovery, it goes back to the boot up screen with the apple logo and stays stuck there at 100%.

  • when I run the AHT (Apple Diagnostics) by holding down the d button, the test runs smoothly and exits with the message "no issues found". When I click "Get Started" it starts booting the os and freezes again in the logo screen.

  • I successfully entered the MacOS Utilities Screen by using a bootable USB drive with macOS mojave on it, but here's what happened
    • The Disk Utility was unable to load any drives or partitions, it only displayed a spinner and pretty much hangs on startup. However the machine didn't hang, I could still exit the Disk Utility. Here's a link with an image of the disk utility: https://m.imgur.com/gallery/MxfSna8
    • When I click "Install macOS" nothing happens
    • In the terminal, when I cd into the Volume "Macintosh HD", then ls, the terminal process hangs.
      • What's odd is that in single-user-mode, lsing around the internal ssd was not a problem.
  • I ran fsck from the single-user-mode, it exits with the message: The volume /dev/rdisk1s1 appears to be OK. I put a link below of a photo showing the console output of the fsck process.
  • When I use the exit command to exit single-user-mode the machine hangs. I put a link below with a photo showing the console output following the exit command.

Log output in single-user-mode: https://imgur.com/a/YPrmtbG

Log output when starting in verbose mode: https://imgur.com/a/6BAQdR8

Result after booting into AHT: https://imgur.com/a/aipanxz

Below i go into details about what I was doing prior to this issue:

  • I ran 8 consecutive node.js processes, to write about 11 GB of randomly generated data to an external SSD.
  • each processes was given about 8gb of ram with the flag --max-old-space-size=8000 (the machine itself only has 8GBs of ram, and there's usually about 3GBs that are always occupied)
  • each process was pretty much writing to a csv file using a for loop and a node fs write stream
  • each processes was followed by a killall -kill node
  • after the processes were done the os started doing unexpectable things so I shut it down. (unexpectable things such as the desktop background image was changed, and all terminals would restart every time I put the macbook to sleep).
  • after shutting it down, when I turned it back on the external ssd was still connected, so I unplugged it right before the apple logo appeared, that's when it hanged.

I appreciate your help!

  • it is recommend to repeat the fsck multiple times (10x) since not every scan caches all problems. – Ruskes Dec 25 '18 at 18:52
  • stupid question I know, but do you have USB with OSX on it – Ruskes Dec 25 '18 at 18:57
  • according to the log you provided your disk and Mojave are compromised (kaput). Using external boot disk you can try to repair that. For example the APFS should be some 50 GB or more and yours is 9MB ? that would explain that it can not find multiple files that it needs to proceed. – Ruskes Dec 25 '18 at 19:21
  • @Buscar웃 so you would say that booting it from an external drive (that has the OS on it) is the only solution at this point? i'm also not sure i quite understand how the APFS and mojave were compromised? if you don't mind explaining. And to answer the question, unfortunately I do not currently have a usb with OSX on it. – Ismael Dec 25 '18 at 19:48
  • just look at your log, it is missing Mojave files and the APFS disk size is way to small. How that happened I do not know. – Ruskes Dec 25 '18 at 20:02
1

I was able to fix this by using a bootable Ubuntu usb to boot my system, and choosing the option for formatting the SSD. Then after installing Ubuntu I was able to use a bootable MacOS usb drive to reinstall MacOS Mojave successfully. As mentioned above, absolutely nothing was working including the disk utility, internet recovery, or using a bootable MacOS USB drive. Everything was causing the system to freeze.

0

@Imael Oooo that is serious. I have had this problem with 10.12, which I believe stemmed from I installed an old Epsilon print driver and the kext file reaped havoc, causing exactly the error you described.

To resolve this I booted into the start-up/recovery drive, (turn the machine on and hit "Alt") and opened Terminal. I then went to the two system directories which held .kext files (I forget them at present) and dumped the .kext file into a temporary folder (so the system couldn't find them). It then booted up fine.

Happy to supply the full details if required, it could have been an issue with earlier OS, because OS 10.14 is quite different.

  • Thanks for answering @Michael. The terminal didn't work either, when I would open the terminal in the recovery/utilities mode the system would freeze up once I ls. Nonetheless I already posted how I solved this above, it was by formatting the ssd completely with an external drive – Ismael Apr 24 at 8:04
  • Okay, if terminal freezes it is not a system conflict with the .kext files. .. there is "single user mode", but I've never accessed it. – Michael G. Apr 24 at 8:07
  • Single User Mode worked perfectly as read only (for viewing the folders and files) but nothing more. I was unable to write to disk or perform any changes – Ismael Apr 24 at 8:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .