0

I just got a new 2018 Macbook Pro, so I'm in the process of migrating from my 2013 MBP to the new one. I don't trust the Migration Assistant due to numerous bad past experiences, so I do this kind of thing manually.

To move my Messages content over, I copied the entire ~/Library/Messages/ directory over to the new machine, and Messages generally seems to work fine - all my messages are there, Text Forwarding from my phone works, etc. The one thing that doesn't work, is search. I can't search for anything at all, no matter what it is. 100% of attempted searches results in "No Results Found".

Is this a Spotlight issue? Is there some trick to make Messages' content searchable?

  • sounds like moving stuff got lost or it is in wrong place – Ruskes Dec 25 '18 at 4:07
  • what is the date and the size of the ~/Library/Messages/chat.db ? and do you still have the old one ? – Ruskes Dec 25 '18 at 4:11
  • I do still have the old as I merely copied the folder, and have not wiped the old machine yet. Last Modified local timestamp is, not surprisingly, just a matter of minutes ago - Today (Dec. 24) at 7:59 PM. chat.db is 274.8 MB – Jonathan van Clute Dec 25 '18 at 4:17
  • so it is using the new db (not yours). Rename that file in to newchat.db then copy the old one into the folder named chat.db. Lets see if that works, unless I got the wrong file. Check the 2 other files in that folder, I think the search is using the newer version and can not find anything. – Ruskes Dec 25 '18 at 4:28
  • You lost me... using the "new db"? The one in use currently started as a copy of the old one (and has since had data added to it as I've been using Messages on this new machine all day). All message history is intact, everything except search works correctly. Are you saying you want me to again copy the chat.db file from the old Macbook, into the new one's Messages directory? Also there is no folder named chat.db, chat.db is a file. – Jonathan van Clute Dec 25 '18 at 4:30
0

I finally got a solution for this in the Apple forums. Still not sure why it worked but, here's what was suggested:

In Sys Prefs>Spotlight>Search Results, uncheck "Mail & Messages" (and leave it unchecked), then add your drive to Spotlight's exclusion pane, wait, then remove the drive from the exclusion pane, wait for Spotlight to rebuild it's index.

I had to leave the machine overnight but this morning, Messages search works again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .