1

I attempted to add a partition to my boot drive in macOS High Sierra. In the process, Disk Utility was going to resize my Container disk1. The boot partition is APFS and is in that container. On the same drive, is my BOOTCAMP partition. I didn't delete any snapshots, but the last Time Machine backup ran a half-hour before I started.

After 2 hours, the Mac is stuck on this screen (I can move the mouse but I can't click on anything):

Disk Utility

Is it normal for this operation to take 2 hrs on a 512 GB SATA SSD? Is adding a partition to a drive which already has an APFS partition possible? Has anyone done this before?

  • I imagine it would take quite a while, generally I'd want to be running on a drive other than the one I'm editing partition maps on. Also the fact you usually don't want to repartition when using APFS, unless you have a specific need for it, I would give it another hour or two. – user3052786 Dec 23 '18 at 22:29
  • You have a good backup of everything on that drive? If not don’t change anything and hope the check completes. I agree with @user3052786 since apfs has to check each and every snapshot and partition that shares space with the container. You could have 10x or 100x the work to do based on the number of snapshots and containers. – bmike Dec 23 '18 at 22:31
  • I do have a good backup. Well, I rebooted. The new partition wasn't created. I deleted my local snapshots (about 20 of them), rebooted into recovery mode, and created the partition there. That time it worked and took about 5 minutes. Maybe add an answer that this sort of thing should be done when booted into the Recovery Partition? I could accept that. – watkipet Dec 23 '18 at 23:00
  • @watkipet I'm still curious why partitioning was necessary though, was it multiple non-macOS installations? I believe this issue with the editing of partition maps was one of the more difficult that had to be resolved before APFS was adopted as the default format, and it is still not completely painless as you've experienced. Kind of like it wants to be a partitioning scheme, and only grudgingly allows for bootcamp to have a slice of its otherwise complete abstraction of the entire drive space. – user3052786 Dec 24 '18 at 1:31
  • Oh, I wanted to partition it because I'm running High Sierra on a Mac Pro 4,1 flashed to a 5,1 with a Radeon Sapphire Pulse RX 580 installed. However, the RX 580 contains PCI option ROM with a UEFI segment which only supports GOP (instead of the UGA protocol that the Mac Pro firmware is compatible with). This means I can't get a boot screen. Without a boot screen, I can't pick my OS on startup. However, by installing a boot loader (abdyfran.co/projects/next-loader) on a separate partition, I can at least blindly pick the OS using the arrow keys. – watkipet Dec 24 '18 at 5:42

You must log in to answer this question.

Browse other questions tagged .