22

On a website I tried to change my login password. After typing it in once, Safari replaced it in both input fields with a generated strong password. In the menu on the bottom I tried to select “other password” (instead of the generated one), but it did not work. Also it seems the new password was submitted to the website as next time I could not log in with the old password.

The problem is, Safari did not remember the new password, so now I’m locked out of the website.

I can start a password reset process, but want first to look for other solutions. Is there any chance the password is stored somewhere?

I googled but only found “this happened to me too and I know no solution” stories.

This was on an iPad with iOS 12.1.1

4
  • 6
    Google search suggests that this is a problem that goes back to 2013 and is still not addressed by Apple: discussions.apple.com/thread/5474245
    – Dr_Zaszuś
    Commented Jan 25, 2020 at 15:59
  • 1
    Hi David. I've just run in to this myself. Safari did (in my case) remember recent passwords it had created but had not put in to the keychain. There's an answer below, but it's not had any other votes. I think it is probably the correct answer, so it could be worth giving it some love! Thanks.
    – Benjohn
    Commented Jan 6, 2021 at 9:29
  • 2
    The issue still happens in 2021. Since Safari can recognize the password input controls on the page and already fills the password, I don’t see any reason safari can't save it.
    – zs2020
    Commented Jan 18, 2021 at 3:42
  • 1
    We have now reached iOS 15 (for iPhones) and this problem continues. In addition, the new password recording process looks totally random. So I always get stressed whenever I ask Safari to create a password for me because I don't know if it will remember it later on. Moreover, there is no way to copy a password created by Safari to buffer so that I can at least manually enter it using iPhone's Settings. (I reckon copying is disabled for security reasons but this leads to other security problems because the intended process itself does not always work.)
    – Alper
    Commented Oct 20, 2021 at 6:31

10 Answers 10

6

Not only you. It happens to me too. And it happens on Mac book pro and iPad pad pro.

The solutions I’ve tried include looking in my passwords; no solution provided. Other solution includes backspacing on that website looking at history, taking a picture of the password (The problem with that is I can never get a full picture of the password as it fades in the field).

I believe that it’s due to the different URLs that the webpage is used when creating a pass. Often I have to go to my gmail to authenticate The password, and then I am directed to a different URL. And then everything is messed up.

What I’m doing is using a password that’s real simple to create an account. Once the account is created I go in and reset the password with the strong password and it seems to work.

1
  • 1
    I don't think it is related to using different URLs because you would still find a password in the stored passwords. Just under a different name. This bug is very annoying.
    – Dr_Zaszuś
    Commented Jan 25, 2020 at 15:57
5

Sadly this is a problem that happens with certain websites, and sometimes due to a small hick-up. (of you followed some of the links on google they all have there reasons, Im sure I don't have to repeat them here)

Why they haven't got a feature (like Dashlane) to show you the recently created but not saved passwords is a mystery to me. AFAIK you'll have to reset your password.

3
  • 3
    Not sure about iOS but you can do this on macOS. Simply put the cursor in the password field on the website in question and it will show you an option to use the recently created password. This probably only works for a short time after password creation. Commented Dec 21, 2018 at 16:17
  • This is pretty sad specially when to change your password you have to know the old one and Safari already generated a new one and didn't save it. FAIL
    – Mark
    Commented May 19, 2021 at 15:46
  • This makes password generation totally useless, as Apple had also the brilliant idea of making the generated password not copiable. They think that it is secure this way, but you will just end up using the same password for everything. It's a huge blow to security. Commented Jul 1, 2021 at 15:33
4

Just ran into this and there is indeed a solution, on your browser. After resetting password I proceeded to the login page, and apple has a suggestion “use password saved from earlier today”. I couldn’t find this password when I tried to login from the app. After filling the saved password , I added the username and logged in. It prompted to update the saved password and then I was able to find it in keychain. Horrible UX

1
  • Also just found this thanks to this comment. This definitely works. It is a terrible UI, but at least its there in some form! Have upvoted your answer as it seems to be the only correct one that addresses the OP (and my) problem. Thanks!
    – Benjohn
    Commented Jan 6, 2021 at 9:26
2

I had this problem recently but worked out it occurred on a website that did not need a username or email address, but only a password.

So when I generated a strong password, it was saved without a name. Then when I went to re-enter the saved password from the automatic prompt I could not find it from the search facility.

Eventually, found it from Settings, Passwords and Accounts then gave it a name for next time.

1

One of the above tips helped me. I updated recommended security alert for a gmail account but it kept not updating the keychain and was repeatedly showing the old stored password unchanged in Apple Passwords. I went to the full list of saved passwords and it was there as an additional new google.com entry. The problem seems to have been that with google you can change your password from typing your account name with or without adding “gmail.com” to your account name. Apple can’t tell they are the same thing. Hope that helps for those with this specific website problem.

1

I had the same issue today. Created a new account for a website, Safari prompted to save password but didn’t and I couldn’t subsequently log-in.

On mobile, I went back to the log-in page and clicked in the password section of the website, the word “passwords” or a key symbol appeared, clicked it and it took me to my passwords with a “Recently Generated” option. I was then able to select the password from there and log-in (and save it).

0

If you log out of the site on which you just created the unknown password, then immediately begin to log in again: at the username/password form Mobile Safari will suggest the password that it recently saved. Cool!

To be able to suggest the password it must have stored it somewhere. Username/Passwords pairs are stored is in the Keychain, referred to as Passwords on iOS/iPadOS.

To find the account details you'll need to search for some specific aspect of it: website (URL), or account name (username).

Keep in mind that a password for gmail.com, for example, may well be stored under google.com so be sure to look for the password with the correct terms.

iOS
Settings > Passwords > (search)

The passwords are synced using iCloud Keychain if you have it enabled, so you can also get at them on your Mac.

macOS
Safari > Preferences > Passwords > (enter macOS user password) > (search)

5
  • 8
    No, it is not there. Commented Dec 21, 2018 at 13:41
  • do keep in mind that a webpage sometimes uses a different URL then the one you normally use, for resetting the password. Commented Dec 21, 2018 at 13:58
  • 2
    @Gert-JanRoeleveld I only have two accounts saved, none is the website in question. Commented Dec 21, 2018 at 14:31
  • Not sure about iOS but you can do this on macOS. Simply put the cursor in the password field on the website in question and it will show you an option to use the recently created password. This probably only works for a short time after password creation. Commented Dec 21, 2018 at 16:17
  • 1
    Happened upon resetting my microsoft account. I found the new password under azure domain instead of the microsoft domain. Happiest moment in that day.
    – mhashim6
    Commented Apr 25 at 14:00
0

I also was having this issue. What I noticed was that when using generate strong password, the pop up at the bottom of the screen, locks the screen. You can’t alter their generated password or copy it. And you can scroll down. So, in my instance, the button to push to submit the password change, was below the popped up password builder and I couldn’t scroll down to get to a submit button that I didn’t even know was there. So no new password was submitted. That locking action doesn’t happen on choose your own PW.

1
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review
    – Alper
    Commented Oct 20, 2021 at 6:17
0

There's a bug in Safari's Suggest Password feature where it appears not to save your credentials after you accept its suggestion. Saving passwords on all browsers are really "hacks" where account and authentication pages are scraped for username and password fields and associated with the site's URL.

Unfortunately, scraping isn't reliable. It's not uncommon for sites to use non-standard field naming conventions, custom field controls, and multipage authentication, making it difficult to detect the password, the username and the trigger conditions for saving them. Consequently, it sometimes saves blank or incorrect login information or doesn't suggest a password.

On rare occasions, it suggests a password but doesn't save it. In my case, for instance, when creating a new site in Godaddy.com, an account is already created with default login information in the settings screen. Since the username is fixed, it's presented as a plain label instead of a field. The password, however, can be changed. It appears as a series of asterisks in a plain label. Clicking on the Change link next to it brings up a dialog with the password and confirm password fields. Safari suggests a password but clicking the change button gives a false impression it has been saved. The autofill doesn't work and is there any record of the user name.

Generally, the bug stems from Safari suggesting a password but never carrying through with. In the case of GoDaddy.com, it's able to detect the password field, but unable to detect the username because its a field, attribute it to the correct URL because it's different from the current page's, and to save the information because Change button's action failed to trigger Safari.

There's really no solution to this bug, but Safari should at the least inform the user if it failed to save the suggested password. Fortunately, it occurs only on a few sites. To avoid the issue, you should double check your password has been saved and inform sites about the problem.

0

This happens frequently, and still happening in Ventura and iOS/iPadOS 16.

It always happens when there is no confirmation password box (only one password box appears)

Sometimes, on macOS, I can find the password by searching all items instead of just passwords. However, iOS/iPadOS don't seem to have that option.

The only 100% solution I've found is to

  • select options and choose your own password
  • enter a password of your choice, then copy the password you entered (if the field will let you), or write it down
  • log out (if the site logged you in), then log into the site again with your new password
  • agree to save it/update it in keychain
  • double-check that it saved properly in keychain - update or create the login information in keychain if there's a problem

Then submit feedback to Apple. If they get enough comments on this, maybe they'll finally fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .