1

It sounds crazy, I know. Usually its the other way round - you can see files in terminal which are not visible in Finder.

I have a problem which is the other way round. I have a folder - /Users/me/OneDrive/stuff/sa that has one PNG in it. OneDrive is saying there is a problem with the file and the folder. I can see both in the Finder, and if I do "info" there is nothing wrong with them (e.g. no spaces or dodgy characters).

However, If I open Terminal, and do cd /Users/me/OneDrive/stuff then ls -ld sa it shows nothing, and if I do ls it is missing form the list. pwd shows I am in /Users/me/OneDrive/stuff.

I am a Unix sys admin - I have tripple checked and what I am seeing should not be possible.

The file and folder are quite old, and have not changed recently.

Any ideas?

  • When you say you open Terminal and do cd /Users/OneDrive/stuff, did you mean to say you do cd /Users/me/OneDrive/stuff ? – Monomeeth Dec 18 '18 at 12:41
  • 1
    The OneDrive Finder extension may not be syncing properly (going by the error you mentioned). In other words, it's telling Finder it's there when in reality, it's not. Try restarting the OneDrive extension – Allan Dec 18 '18 at 12:52
  • @Allan this could be it. How does one restart the onedrive extension on mac? I have tried restarting the onedrive process, which doesnt seem to help. The dir is in finder even if I kill onedrive. – John Little Dec 20 '18 at 10:39
  • Right click the OneDrive icon in the menu bar, click the three vertical dots and then select "Quit One Drive." Restart it by relaunching. Easiest way is to press Command-Space and type "OneDrive" – Allan Dec 20 '18 at 11:01
1

Okay, same problem here. I just installed a Go package library from github.com which resulted in $GOPATH/src/google.golang.org folder showing in Finder but not showing or accessible in Terminal. I can even open the files in both Finder and in my JetBrains editor GoLand with no problem. But I have no means of going to the directory in Terminal.

I also can confirm they are not symbolically linked either. When I run ls -la on the $GOPATH/src folder I just get github.com but in Finder it shows github.com and google.golang.org as sub-directories under src directory. I have Read/Write permission on both sub-directories.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .