1

Very often, as I'm listening to an article being read by an American English voice with swipe-down "Speak Screen" or selected-text "Speak Selection." A date or number would be spelled in Dutch by the Dutch voice, or a name in French by the French voice, which would often prompt that voice to take over and continue reading to me the English text with the same enthusiasm, even if the words make absolutely no sense: It's just English with a terrible French or Dutch accent.

I haven't found a way to turn this autonomous language switch off. I looked in Accessibility -> Speech and Accessibility -> VoiceOver to no avail. There hasn't been a single time in which said feature was useful, I don't read multi-languages text, or see why a date or a number should be spelled in Dutch. I don't speak or use either language.

  • so you want it to translate to English first then read it to you ? – Ruskes Dec 18 '18 at 8:35
  • "...with the same enthusiasm, even if the words make absolutely no sense: It's just English with a terrible French or Dutch accent." I'm having a good laugh at your unfortunate plight, @Ronen. Unfortunately, I have no idea how to fix this. Are the sites you're visiting which speak in this odd manner served from other countries? Perhaps in some way iOS recognizes the geographical source of the html and tries to voice render the text using this locality. That's just an inspired guess. Good luck! I look forward to seeing if there is a solution! – IconDaemon Dec 18 '18 at 12:16
  • @Buscar웃 no translation, just reading the screen. – Ronen Dec 18 '18 at 17:14
  • @IconDaemon thanks, but it's everywhere, and usually it's the numbers that switch the language. Doesn't depend on origin country. – Ronen Dec 18 '18 at 17:15
  • well it reads what is on the screen, however it is to clever for its own good, and knows when something is in Dutch so it will read it in Dutch ... dinsag achttien, december, tweeduizend achttien, can be read in English but not understood – Ruskes Dec 18 '18 at 17:20
2

Go to Settings -> General -> Language and region and make sure that English is at the top of the list:

image

  • English is number one on the list. I deleted the other languages (although I have no germanic languages in the list). If I see that works for a while I'll accept the answer. Thanks! – Ronen Dec 18 '18 at 17:13
  • English was on top on the list, I had to delete other language options so it doesn't switch – Ronen Dec 26 '18 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .