1

Today I installed a Samsung 970 Evo 1TB on my 13" mid 2014 MacBook Pro. I used an adapter that is not the small sintech one that everyone else seems to be using but is a different sintech similar one with a full length pcb.

enter image description here

enter image description here

Once I went into the system recovery mode (Command + R), and went into Disk Utility to detect and recover my backup onto the new SSD, but it didn't show up.

Things I have tried:

  • Moving SSD around in adapter.

  • Moving the adapter around.

  • Adjusting both connections.

  • Using the Apple provided screw and different combinations of pressure.

I might be, but hopefully didn't, mess up the adapter choice or installed it wrong, but I just want to fix soon to dual boot since I only have 128 GB.

  • In Disk Utility, try erasing the SSD first. – Allan Dec 18 '18 at 3:05
  • Same person here but I logged in through google instead of using a guest account. How do I erase the ssd? I have do this multiple times with other drives but my main problem is that macOS doesn't recognize the drive at all. It doesn't show up in diskutil list or disk utility. – James Singhal Dec 18 '18 at 3:33
  • Did you follow these instructions from the web page? pc-adapter.net/files/… – Allan Dec 18 '18 at 3:36
  • Make sure you are running macOS 10.13.6 or later, since that is the first version of the OS that supports NVMe drives. – user128998 Dec 18 '18 at 19:43
1

Make sure in disk utility you have show all selected and not just volumes. A bare unformatted drive is usually not shown especially in Mojave and high Sierra where they introduced apfs. Click on the gear or down arrow and show all devices in the left side are of disk utility and see if you can then see the nvme, click on the very root of the drive not a volume and format it to apfs. If you don't see it to do this, then you have a bad adapter probably and should buy the one that's most recommended. Nvme support isn't as great as I'd hoped on my 2014 MBP either. I fixed the slow to restart and sleep issue but the system still doesn't recognize it at boot for almost 20seconds (,even after selecting it as the startup disk as many have suggested, that didn't help a thing for me) it simply takes several seconds to see it unless I boot and hold option key and then select it which is much faster to show it but still a pain to have to do. I actually pulled mine and use it in my m. 2 slot on my Windows Z390 Mobo instead as I restart and or sleep the Mac allot in my work (I'm in and out of car a lot) so it really wasn't practical for me. But try showing all devices in the left pane.... It should be there if you don't have a bad adapter.

1

you will need to set it up with high Sierra 10.13.6 and it will recognize it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .