4

The LG TV just says "no signal". I'm connecting the Mac Mini to another TV just fine (1080p though). I'm using the same cable to connect a Windows 10 machine and it works over 4K just fine.

Is there some setting I need to set in order to make this work?

3

Here's what I had to do to make it work:

  1. Upgrade WebOS to latest version
  2. Switch to appropriate HDMI input (HDMI2 in my case)
  3. Turn ON "ULTRA HD Deep Colour" for HDMI2 (pictured below)

ULTRA HD Deep Colour ON

  • 1
    I had a similar problem with and LG 4K TV - everything worked except an HDMI support. LG swapped out the main board and suddenly my 4K support from a PC stopped working. It too was fixed with a firmware update. I had forgotten about it until I saw this post! Thanks for sharing as this will definitely help someone else! – Allan Dec 18 '18 at 13:23
  • 2
    I just bought a new Mac mini to run as a headless computer, and had the same problem with my LG C8 when I was trying to set it up. At first the Mac mini displayed on my LG C8, but once I upgraded the software on the Mac mini during initial setup, the LG and mini did not connect. This post saved my bacon. Thank you. – Loubendor Jul 21 at 15:05
  • 1
    Ohhhh man! Thank you so much! Was about to return my LG 43UM73. The "ULTRA HD Deep Color" option did the trick. Before I turned it on, I only had 30 HZ refresh rate. After I turned it on, now have 3840 x 2160 @ 60 Hz. Note - I'm using an USB-C (on Mac mini) to HDMI (on LG TV) cable for the connection. – ckib16 Aug 10 at 0:25

You must log in to answer this question.

protected by bmike Jul 21 at 15:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .