1

I'm trying to update my Macbook Pro to the latest security update for High Sierra but the download doesn't seem to finish and is working in a really weird way. I tried to cancel the current update, and it does cancel, but when I try to start it again, it doesn't start from the very beginning and shows an entirely different progress than what it showed before I cancelled it. For instance, I cancelled the download at around 700mb, but when I tried up update again, it shows that only 300mb has been downloaded. I want to start the download from the start, from 0%, which I think will fix the issue but I can't seem to do that, too. Can anybody please help me? I tried to wait it out already, but it just gave me a connection error around 1.6GB. When I tried to start again, it started at around 738mb.

  • I would try a different approach and download from here: support.apple.com/en_US/downloads As far as I know High Sierra downloads tmp system updates to a file similar to this: /private/var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068/C/com.apple.SoftwareUpdate/CFNetworkDownload_XxxXxX.tmp then assembles it into a subdirectory, before moving it to /Library/Updates/. You can always boot into "Recovery", which should let you browse all directories. Also a safe boot with an installation attempt there often helps. – Redarm Dec 17 '18 at 14:46
1

Sorry, but I only have a partial answer to your question:

First off I would try a different approach and download from here:
https://support.apple.com/downloads

Also a safe boot (pressing and holding the shift button at boot until the Apple symbol appears) with an installation attempt there often succeeds.

As far as I know High Sierra downloads tmp system updates to a file, or files similar to this:
/private/var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068/C/com.apple.SoftwareUpdate/CFNetworkDownload_XxxXxX.tmp
...then assembles them into a subdirectory, within... /private/var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068/C/com.apple.SoftwareUpdate/swcdn.apple.com/content/downloads/
...before moving them to...
/Library/Updates/.

You can always boot into "Recovery", which should let you browse all directories in Terminal (to be found under the "Utilities" menu).

  • I suppose I'll go with this instead. Also, I think it worked! Deleting the files, I mean. I deleted the files in the said directories but they App Store continues as if I've deleted nothing. However, when I booted into safe mode, everything went perfectly fine. – Xykros Dec 17 '18 at 15:26
  • I've just observed the updates being downloaded to the system cache and moved the way I've described. I've never tried to actually delete them; with all the other options to fix the issue, I never saw the need. – Redarm Dec 17 '18 at 16:00
0

This seems to be due to an interrupted or corrupted download. This can usually be resolved by clearing your Mac App Store cache.

  1. Quit the Mac App Store
  2. Go to Terminal and type following: open $TMPDIR../C/com.apple.appstore/
  3. Move the files inside the folder to the Desktop or any temporary location (if you are confident, you can move them to Trash straight away.)

This should resolve the problem as temp files are cleared. For more information, read http://osxdaily.com/2016/10/08/mac-app-store-temp-cache-folder/.

If it is still not working, locate the folder /private/var/folders and open each subfolder inside it until you find com.apple.appstore. This stores the partial downloads. Do not delete any other files, only folders named com.apple.appstore.

  • This won't work. I also tried browsing folders in the /private/var/folders but I can't access some folders, so in the end I can't really delete anything. It says that I don't have the permission despite the fact that I'm using the admin account. – Xykros Dec 17 '18 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .