1

I'm using my Mac Mini as a TimeMachine host. I have a couple of external drives plugged in via USB. TimeMachine doesn't work unless I use Finder to manually Browse the network and mount the volume after each reboot or Wifi change (e.g. when I've taken the MacBook on a work trip).

Is there a way to have macOS or a script on my MBP to automagically mount the volume on the Mac Mini? Maybe something that checks every 30 minutes and remounts if it is not already?

Edit: I have two home Wifis - one super-fast 4G with limited bandwidth, and the default one backed by ADSL, so I switch to the 4G one when I need to videoconference, and back to the default one to use the printer or connect to other devices at home.

  • Which device(s) are rebooted or have a Wi-Fi change, the MBP, the Mac Mini, or both? Please edit the question or comment for clarity. – IconDaemon Dec 17 '18 at 10:13
  • Both, but normally when the MacBook has been out of the house. I updated my comment. – Nic Cottrell Dec 17 '18 at 19:29
1

The way to mount the drives on the Client at login is:

  1. Mount the Network Share.
  2. Open System Preferences > Users & Groups.
  3. Drag the drive's icon and drop it onto the list of Login Items for your user.

WiFi change? How often do you change Wifi? If the TM share and client aren't on the same network, then obvs that won't work.

However, TM shares should normally work without the need for a Finder connection, so there may be another remedy to your original problem.

  • Had no idea you could add volumes to Login Items! Very nice. I added an explanation for my weird Wifi setup. Thanks for the help so far. Any other thoughts? – Nic Cottrell Dec 17 '18 at 19:34
  • As said, if the two WiFi connections represent separate Local networks, then obviously the client MBP won't find the Mini server if they're on separate networks. I would recommend an app called mDNSBrowser, which shows you the local services available to the client. (Run it on the MBP.) You should be able to see the Time Machine service without the Finder shares. If not, then perhaps your home router is blocking the mDNS. – benwiggy Dec 18 '18 at 10:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .