i noticed the following problem with my MBP 8,1 running 10.7.2 — automatic sleep just doesn’t happen. Since I usually put my Macbook to sleep manually before leaving the desk etc. I just noticed this issue and can’t really pinpoint it to specific updates.

What happens automatically is display sleep. Computer sleep just doesn’t occur.

Closing the lid works, selecting “sleep” from the Apple menu works. The only way to put my MBP to sleep automatically is currently PleaseSleep, which works fine.

Here’s pmset -g:

pmset -g 
Active Profiles:
Battery Power       1
AC Power        -1*
Currently in use:
 standbydelay   4200
 standby    0
 womp       1
 halfdim    1
 panicrestart   157680000
 hibernatefile  /var/vm/sleepimage
 sms        1
 networkoversleep   0
 disksleep  10
 sleep      10
 hibernatemode  3
 ttyskeepawake  1
 displaysleep   3
 acwake     0
 lidwake    1

As you can see, no process is preventing sleep.

Here’s pmset -g assertions:

pmset -g assertions
25.12.11 03:05:34 MEZ   
Assertion status system-wide:
   ChargeInhibit                           0
   PreventUserIdleDisplaySleep             0
   PreventUserIdleSystemSleep              0
   NoRealPowerSources_debug                0
   CPUBoundAssertion                       0
   EnableIdleSleep                         1
   PreventSystemSleep                      0
   DisableInflow                           0
   DisableLowPowerBatteryWarnings          0
   ExternalMedia                           0

Kernel Assertions: 0x0004 
 * Kernel Assertion ID = 500
   Created At = 01.01.70 01:03:17 MEZ   
   Modified At = 25.12.11 02:46:14 MEZ   
   Owner ID = 0xffffff800b664000
   Level = 255
   Assertions Set = None (4)

 * Kernel Assertion ID = 501
   Created At = 01.01.70 01:03:21 MEZ   
   Modified At = 01.01.70 01:00:00 MEZ   
   Owner ID = 0xffffff800b674000
   Level = 0
   Assertions Set = None (4)

 * Kernel Assertion ID = 502
   Created At = 01.01.70 01:05:31 MEZ   
   Modified At = 25.12.11 02:38:13 MEZ   
   Owner ID = 0xffffff800b704200
   Level = 0
   Assertions Set = None (32)

Any ideas? I tried resetting the SMC, to no avail.

Bluetooth is off, Sharing is off. Automatic sleep doesn’t occur both on power adapter and battery power. Unplugging USB hub with things like keyboard/mouse connected makes no difference.

Thanks in advance!

EDIT Just booted into safe mode, and automatic sleep definitely works then.

EDIT 2 After removing Google Software Update, automatic sleep miraculously started working again.

  • I'm not familiar with pmset. What are you expecting it to show when sleep is being prevented? I have Caffeine turned on right now and the output from my pmset looks almost exactly the same as yours. Commented Dec 25, 2011 at 2:33
  • Have you tried setting the computer sleep time in System Perferences > Energy Saver to something else? Say 5 minutes? Sometimes manually sliding the bar triggers the proper event again.
    – user10355
    Commented Dec 25, 2011 at 2:35
  • i have exactly some problem with you? and check the process 500, 501, 502 but there is no process running
    – user15495
    Commented Dec 25, 2011 at 3:12
  • @MitchLindgren It should look something like this: sleep 0 (imposed by %processnumber) macobserver.com/tmo/article/…
    – user15491
    Commented Dec 25, 2011 at 12:14
  • @cksum Yes, I tried setting computer sleep to 1 and 2 minutes.
    – user15491
    Commented Dec 25, 2011 at 12:16

2 Answers 2


Do you have Bluetooth turned on and if so, in the advanced tab of the bluetooth preference panel to you have the checkbox checked that allows bluetooth devices to wake your computer?

I had a similar problem and found that my magic mouse was preventing hibernation with the lid open.

  • Bluetooth is off, no Magic Mouse or other bluetooth peripherals.
    – user15491
    Commented Dec 25, 2011 at 13:56
  • Wake for network access checkbox in Energy Saver?
    – Richard
    Commented Dec 25, 2011 at 15:39
  • Doesn’t help — no automatic sleep, no matter if “Wake for network access” is checked or not. Just found out though that in Safe Mode, automatic sleep works. A 3rd party app or extension has to cause this.
    – user15491
    Commented Dec 25, 2011 at 16:00

I made two changes:

  • Disallowed bluetooth devices to wake up computer;
  • Uninstalled google notifier.

Now the computer will sleep

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .