I want to download apps in the Mac App Store and the apps won't start to download. As you can see in the pictures below, the spinner starts spinning but nothing gets downloaded, the download simply doesn't start. I am logged in with my account. I tried logging out of the App Store and logging in again, restarting the Mac etc, nothing helped.

This is a relatively fresh installation of Mojave 10.14. Before with High Sierra 10.13 everything worked fine. It's a Late 2013 MacBook Pro 13". Installations are allowed from App Store and identified developers.

Some screenshots from Console output below.

enter image description here

enter image description here

  • what is your setting in the System preference > Security & Privacy ....Allow Download from ? – Ruskes Dec 16 '18 at 20:52
  • @Buscar웃 Downloads are allowed from App Store. Downloads seem to start but there is no progress shown, and also no error message. – greenforest Dec 20 '18 at 11:19
  • 1
    Great details from Console. Does your Mac trust the SSL certificate in Safari for appleid.apple.com and other signed TLS/SSL traffic? This seems to be all about your network not getting a secure connection to the store to do the download. – bmike Jan 13 '19 at 16:14
  • I added the TFA portion to my answer. Anything else to button this up for you? – bmike Jan 18 '19 at 12:56

This could be related to two factor and/or two step authorization, so be sure to log in to you AppleID from Safari and or another browser to check your password and account status for any locks.

At a high level, the App Store is a global network of load balancers that provide listings to make up the content you see in the App Store. It has a second level of load balancers that handle the transition to "buy" anything and once that transaction happens, then your account will go initiate the request to download a purchased asset.

Lots of things can go wrong and usually it's with the network or one of the servers behind the load balancer that's stuck and the load balancer doesn't know that it's broken and route around that one failure on one server.

Practically, you can and should wait as a first step. Log out, restart the Mac, get some tea or coffee and try again. When you have a persistent failure, then here's how I attack it.

  1. Verify that the purchase was made by reloading the App Store purchased tab and verifying the item cleared the purchase and was assigned to my Apple ID.
  2. Verify you can download anything you purchased in the past.
  3. Retry the item you wanted.

By knowing if it's an issue with allocating that item to your account, you can do very little except sign out, sign in, try another account on your Mac or another Mac and then contact store support for purchasing support.

If you can purchase the item but can't download it or the other one - now you're back to figuring out the network of content delivery servers.

Also, the App Store can tell you if it's working well if you look at an app you have a backup or can afford to re-download once your account is set. Find that app in purchased and move it to trash. The App Store should change from telling you it can open that app to it can download that app pithing a few seconds of moving that app to Trash. If you attempt to re-download it, the console app will log hundreds of diagnostic messages to the logs.

As long as you see TLS Events you'll know that secure communications from your App Store App to Apple's load balancers is being attempted.

Searching for App Store messages in the Console.app

| improve this answer | |
  • Thanks for the long answer. I can see my purchases in App Store but not download any of them. No error message. A line like highlighted in your screenshot doesn't appear in my console when trying to connect to the App Store. Logging out and back in as well as numerous restarts didn't fix the issue. Strangely also iTunes won't load properly anymore on my Mac, not sure if this is related. I attached a screenshot of the console to the question above. – greenforest Jan 13 '19 at 14:44
  • @greenforest So - your network is blocking the requests to the load balancer or your DNS is not resolving the load balancer properly. Great description of where you’re getting blocked. That TLS error can be caused by security software that tries to decrypt / inspect traffic. Who manages your network and do you have any web security installed? – bmike Jan 13 '19 at 16:08
  • Thanks @bmike. It’s my private computer and internet access, so I guess I manage it :) No additional security software installed that I know of. – greenforest Jan 14 '19 at 11:18
  • Bummer @greenforest - Sometimes workplaces add security software that breaks this. Assuming your ISP isn't manipulating your traffic - this should clear up the instant you take your Mac to another location. Is it viable to tether that Mac to in internet hotspot to confirm? An iPad or iPhone with data connection would be worth joining over WiFi to get a different network connection. – bmike Jan 14 '19 at 12:10
  • 1
    @greenforest Wow, that's a very interesting fix to your situation. I'm going to remember that the next time I need to troubleshoot something like this for someone - would be good to know if this is a repeatable problem/solution. Thanks for coming back to share it. :) – Monomeeth Jan 15 '19 at 23:47

I believe there can be multiple reasons for this behavior and various solutions. Too bad that app store simply does not give any indication of what is wrong with it.

The problem happened to me too. Nothing from this topic helped me. The only thing that worked is going to Activity Monitor and force-killing appstoreagent process. The app started to download at once.

| improve this answer | |
  • Nice, worked for me too. – willem Mar 3 at 5:33
  • This worked for me as well. – calebx Mar 3 at 15:26
  • This worked for me too. Should be the selected answer – GabrielBB Apr 7 at 9:19
  • That was easy. Thanks! – Danil Apr 20 at 3:47

I had same symptoms as greenforest except after signing out I was unable to sign in (500 error). Then I found another stack exchange answer by Adrian Voica which fixed the sign in issue, and after a restart, also let me download apps as expected.

Here is the process:

  1. Sign out of App Store.
  2. Close the App Store.
  3. Run this command in Terminal:

    defaults write com.apple.appstore.commerce Storefront -string \
        "$(defaults read com.apple.appstore.commerce Storefront | sed s/,8/,13/)"
  4. Sign in to App Store.

  5. Restart Mac.
| improve this answer | |

I've had the same problem when upgrading from macOS 10.12 to 10.14.3, with a late 2013 mac book pro. No App Store updates were going through, and the spinner kept on spinning.

Console showed a lot of "AMSURLRequest: Failed to fetch GUID schemes from bag" error messages.

What helped me was to sign out of the App Store and reset the PRAM as described in https://support.apple.com/en-us/HT204063

Once I rebooted, macOS said that there was an issue with my iCloud account, so I had to log in again in System Preferences, as well as in the App Store account.

Once I've done that, I could successfully update App Store applications.

| improve this answer | |
  • +1 Nice, thanks for sharing your experience. Seems it's similar, i.e. related to signing in into the apple account. – greenforest Feb 20 '19 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .