0

I've got a MacBook Air 2013 running 10.14, and loading all pages either stalls for multiple seconds on "Resolving host" and only loads after a painful delay or it completely fails and Chrome shows me a "Could not resolve DNS error." This is consistent across browsers, so I'm inclined to believe this is an OS issue.

What's throwing me for a loop is: this only happens on one network! The router has a 2.4Ghz and a 5Ghz network, and they both have this problem. The only way I can use the internet without tearing my hair out is to tether to my phone.

Any ideas? Maybe I have a forgotten DNS setup that only fails on this router/ISP combo and I need to reset my DNS settings?

  • 1
    It may be that the DHCP server on that network (which is probably the router) is handing out bad DNS server addresses. Open the Terminal utility, and run cat /etc/resolv.conf -- its last few lines should start with "nameserver" followed by a DNS server address (e.g. "nameserver 10.0.0.1" or "nameserver 2001:558:feed::1"). Test each of those servers separately with e.g. host www.google.com 10.0.0.1, host www.google.com 12001:558:feed::1 etc (substituting the DNS server addresses from your resolv.conf file). My guess is that one or more of them is responding slowly or not at all. – Gordon Davisson Dec 16 '18 at 6:01
  • @GordonDavisson I tired your suggestion (I do not have slow problem), but how do i know what is considered slow – Ruskes Dec 16 '18 at 6:28
  • all i get is like instantaneous respond `host www.google.com 8.8.4.4 Using domain server: Name: 8.8.4.4 Address: 8.8.4.4#53 Aliases: www.google.com has address 216.58.216.100 www.google.com has IPv6 address 2607:f8b0:4009:800::2004 – Ruskes Dec 16 '18 at 6:30
  • Have you tried using another device to verify it's an issue with that computer only? – JMY1000 Dec 16 '18 at 6:31
  • 1
    @Buscar웃 host should come back with a response pretty much immediately. A delay of a second or so would be enough to make browsing painful (given the number of additional domains each page tends to pull images/scripts/ads/etc from, 1 second per domain would be bad). But from Alex's description, it sounds even slower than that. My guess would be that there are multiple DNS servers, and one (or more) isn't responding at all, but until we get the test results that's just a guess. – Gordon Davisson Dec 16 '18 at 6:38
1

Thanks for all the suggestions. I verified that this is indeed only a problem on this machine, so I figured it must be something misconfigured.

I found that I had Cloudflare's 1.1.1.1 (and associated backup and IPV6 addresses) as manually-set DNS servers for only this network. When I removed these addresses, my lookups became blazingly fast.

The mystery is now: why is 1.1.1.1 so slow? I set these as my DNS servers on my iPhone and it's nice and fast. I'll mark this question as solved because my original question has been resolved, but it have generated another bigger question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .