11

I wanted to use a USB audio input to record a video, and got something I've never seen before having done this 100 times; it asked "Authorize Quicktime to use the microphone?" I clicked no, because I didn't want it to use the internal mic, I wanted it to use a USB input. Now, it won't let me get rid of the denial. I've quit QT, quit & reopened it twice and it still won't let me choose ANY input source. It still says it doesn't have access to the microphone. Is this a new Mojave 10.14.2 bug or what? How the heck do I get out of this? Thanks!

10

Go to System Preferences > Security & Privacy > Privacy > Microphone, unlock the preference pane by clicking the padlock symbol at the bottom left of the window and tick "QuickTime Player.app", which should be listed without a tick mark in its checkbox.

If QuickTime Player.app is missing, you should be able to reset all decisions you made for the various applications that asked for access to your Microphone by quitting System Preferences, opening Terminal (to be found in /Applications/Utilities/, or search via Spotlight) and running the following command:

tccutil reset Microphone

...then press enter.

This should clear all applications from the Microphone section and after launching QuickTime Player, it should ask for permission to the microphone all over again.

| improve this answer | |
  • It's noteworthy that this erases all of the apps that have already requested access, and depending on the logic of the app, they might not request access again. Use with caution. – Chaim Eliyah Aug 25 '19 at 18:59
  • 1
    @ChaimEliyah I added an answer that avoids wiping out microphone permissions for other apps. – Nic Mar 13 at 17:14
2

This new requirement to authorize Microphone was added in macOS Mojave (10.14).

The answer from Redarm is very good, and the best answer for people using macOS Mojave (10.14). But there is a slightly better option for people using macOS Catalina (10.15) or newer. This will reset the privacy settings for QuickTime Player only, without affecting microphone permission settings for other applications.

tccutil reset Microphone com.apple.QuickTimePlayerX

Note that you must quit and restart QuickTime Player after running this command.

| improve this answer | |
1

For me QuickTime was not sharing my iphone screen as well. My QuickTime started showing this warning:

can not use Vaibhav's iphone. This app is not authorized to use Vaibhav's iphone quicktime

What I did: Go to System Preferences > Security & Privacy > Privacy and follow these steps: enter image description here


enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .