8

Running Yosemite 10.10.5 on MacBook Air (early 2014), with Safari v. 10.1.2.

New Safari windows come up blank. Typing a URL into them doesn't load the pages.

Quitting Safari and relaunching causes System error:

Safari cannot be opened because of a problem.

Check with the developer to make sure Safari works with this version of Mac OSX. You may have to reinstall the application. Be sure to sure to install any available updates for the application and Mac OSX."

Crash report (and launching Safari from Terminal) shows this error:

dyld: Library not loaded: /usr/lib/libcrypto.35.dylib
  Referenced from:     /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice
  Reason: image not found
Trace/BPT trap

Listing the directory shows that files were updated here (presumably because of iTunes update) that are proximate to this problem:

drwxr-xr-x   3 root  wheel      102 Dec 14 08:52 AppleMobileDeviceHelper.app
drwxr-xr-x   3 root  wheel      102 Dec 14 08:52 AppleMobileSync.app
-rwxr-xr-x   1 root  wheel  4119552 Oct 16 21:31 MobileDevice
drwxr-xr-x  45 root  wheel     1530 Oct 16 21:31 Resources
drwxr-xr-x   3 root  wheel      102 Oct 16 20:49 _CodeSignature
-rwxr-xr-x   1 root  wheel    43936 Oct 16 21:31 reenumerate_ios_devices

(two December 14th files indicate recent update compared to older files)

Timestamps of those updated files coincide with iTunes being updated to 12.8.1.2.

Hypothesis: Updating iTunes to 12.8.1.2 updated /System/Library/PrivateFrameworks/MobileDevice.framework to a version incompatible with Safari 10.1.2. Workaround 2 (below) supports hypothesis.

WORKAROUND 1: Install/Use Firefox

WORKAROUND 2: Move /System/Library/PrivateFrameworks/MobileDevice.framework to the trash (or somewhere else) WORKAROUND 3 (not yet verified but presumed to work): Install macOS Mojave.

Posted here in case someone has a direct fix for users who can't update to Mojave, don't want to lose capabilities that MobileDevice.framework provides, and can't (or don't want to be forced to) switch to Firefox.

  • To address the previous comments: 1. Safari updates itself. 2. The file is not on the system, Apple probably forgot to include it or linked to a version not existant on Yosemite. 3. /usr is definitely not a user library, it is the UNIX path to where non-kernel (userland) software reside (among other things). – geira Dec 14 '18 at 22:23
  • Confirmed Workaround 2. Tks for the solution! – Kokanee Dec 15 '18 at 16:47
  • 2
    I can't post an answer because the question is protected by the community, but in my case, copying /usr/lib/libcrypto.35.dylib and /usr/lib/libssl.35.dylib from another computer (in my case, running OSX 10.14.2) to /usr/lib of the computer running10.10.5 solved the problem. – zero0cool Dec 16 '18 at 19:58
  • There was a patch released, open up AppStore and download the iTunes update – Logan Bailey Dec 17 '18 at 2:25
  • @zero0cool solution works! – Frank Hintsch Dec 22 '18 at 14:47
5

Same happened to me--same error, same OS X and same Safari version. The following files in /System/Library/PrivateFrameworks/ had today's timestamp on my computer. I restored these files from my backup in Time Machine. Safari is working again.

drwxr-xr-x  5 root  wheel  170 Dec 14 12:30 iTunesAccess.framework
drwxr-xr-x  6 root  wheel  204 Dec 14 12:30 CoreFP.framework
drwxr-xr-x  6 root  wheel  204 Dec 14 12:30 CoreADI.framework
drwxr-xr-x  5 root  wheel  170 Dec 14 12:30 MobileDevice.framework
drwxr-xr-x  5 root  wheel  170 Dec 14 12:30 DeviceLink.framework
drwxr-xr-x  6 root  wheel  204 Dec 14 12:30 AirTrafficHost.framework
  • Also running Yosemite 10.10.5 on iMac (2009), with Safari v. 10.1.2., Apple auto upgraded iTunes and several other apps last night, my Safari froze, thought it was my internet connect, restarted Safari, but wouldn't start, coming up with generic problem statement, Ignore or Send to Apple. Search the internet using Chrome, and came across your post. So I just deleted the files in /System/Library/PrivateFrameworks/, tried Safari again and it came up. Thanks for the advice. – D C Dec 14 '18 at 22:38
  • Deleting these files may affect the ability of your Mac to connect to mobile devices, for example, from iTunes. – user1214836 Dec 15 '18 at 1:32
  • If you are able, you can update to a more recent OS that may not suffer from this issue. – user1214836 Dec 15 '18 at 1:33
1

Indeed, updating the OS to a newer version works. I updated from Yosemite to El Capitan to solve this.

0

Another fix I have successfully used twice is to copy two library files from a newer OS, in my case El Capitan. The files are:

'/usr/lib/libcrypto.35.dylib' '/usr/lib/libssl.35.dylib'

To access this folder use Finders "Go to Folder..." (Shift-Command-G) and type "/usr/lib".

No restart requird, Safari launches perfectly once the files are in place.

You must log in to answer this question.

protected by Community Dec 14 '18 at 22:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .