1

I'm running Mojave on a MacPro5,1 (previously 4,1), which requires using an upgraded GPU, and I'm using the Radeon RX580 (which is listed by Apple as supported). I need to disable SIP to enable continuity on the upgraded Bluetooth module I've installed. Holding Command+R when booting to go to recovery mode doesn't show anything on either of the displays I have connected. Is there a way to disable SIP without being able to see a display, or a route that would be able to display via a third-party GPU?

Thanks

1

You should be able to use the keyboard in order to boot into recovery mode and execute the command while "blind". Do the following:

  1. Boot your Mac while holding down the +R keys.
  2. Wait 3-5 minutes for your computer to boot up. It will likely boot more quickly than this, but better to be safe.
  3. Press the following sequence of keys:

    • fn+ctrl+f2 (leave out fn if it's not on your keyboard)
    • x4 (press the right arrow key four times)
    • x4 (press the down arrow key four times)
    • enter
  4. Wait around ten seconds to give the terminal time to open. Then, type csrutil disable and press ENTER.

  5. Wait another ten seconds, then type reboot and press ENTER again. Once your computer boots back up, SIP should be disabled.

This was tested on a 2015 Macbook Air running macOS 10.14.1.

  • Thanks for finding that thread—didn't show up in my searches. Something's not working though—I'm issuing both commands, and it's reaching the command prompt, as reboot successfully reboots the machine (or at least the GUI comes back up an appropriate amount of time after typing it), but running csrutil status in a terminal window after rebooting shows that SIP is still enabled. – Ed Bennett Dec 14 '18 at 16:34
  • I have a similar setup but with a flashed card, so I can have a look in a couple of hours (on phone at the moment ) I have a vague recollection of something in that changing with Mojave. – Tetsujin Dec 14 '18 at 17:03
  • @EdBennett After testing on my own machine, I think I know what happened. It looks like you can't boot into single user recovery anymore, for some reason; you were in normal single user mode, so the csrutil command didn't work. Please try updated instructions—I tested them on myself (not looking at my screen) and it worked for me. – Wowfunhappy Dec 14 '18 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .