3

Since yesterday my MacBook charges really slow, so I gave coconutBattery a try, and it showed that my MacBook is only charging with around 14 Watts. I am charging with an Apple 86W Power Supply.

So my question is with how much Watt are batteries supposed to charge?

  • first step with battery related issues is usually resetting the SMC – startTerminal Dec 14 '18 at 8:02
  • I already did that because my battery wasnt charging at all yesterday. Now I got it charging but I think its really slow. – Matthias Reumann Dec 14 '18 at 8:04
  • does the battery seem to discharge a lot? bad battery life and bad charging are usually signs of a dying battery (even if the software says otherwise). Did you buy the computer used & how long have you had it? – startTerminal Dec 14 '18 at 8:06
  • I got it since June 2017. Batterylife is normal as well as performance. Its just charging really slow. Do you think there can be a problem with the usbc slots? – Matthias Reumann Dec 14 '18 at 8:08
  • it's unlikely that every single usb-c slot isn't working, you may just have a bad battery or whatever else controls the input wattage. 13.77 watts is abnormally low. can you double check what it says here for the wattage? – startTerminal Dec 14 '18 at 8:12
1

Checking your charging status within macOS

macOS provides a great deal of information about your power usage. To access this follow these steps:

  1. Go to Apple > About This Mac

  2. Click on the System Report... button

  3. In the left pane under the Hardware heading, select Power (it's about 2/3 of the way down)

  4. On the right-hand side, scroll down to view the AC Charger Information

  5. This will show you whether it's connected to a charger, the amount of wattage it's receiving, and if it's currently charging or not

Typically for your model MBP it should show about 85W/86W when connected to an Apple 87W USB-C Power Adapter. Assuming you're getting this figure, you should be right in terms of your charge rate.

As for the figure in coconutBattery, remember:

  • this will vary depending on how much load the MBP is currently under
  • it's not a reflection of the total wattage as most will be used by your MBP for its power requirements

If you're not seeing near the 85W/86W, then read on.

I know you've stated that you've already reset the SMC, but I'd do both a NVRAM and SMC reset (in that order). Before following the steps below, ensure you have no external hardware connected and that you're using the built-in keyboard.

Reset the NVRAM

Reset the NVRAM on your MBP as follows:

  1. Shut down your MBP. That is, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down for about 20 seconds or until you see the Apple logo
  4. Let go of the keys and let your MBP reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

  1. Shut down your MBP
  2. Press and hold the power button for at least 10 seconds
  3. Let go of the power button and wait 5 seconds
  4. Power up your MBP again

Once you've reset the NVRAM and SMC use your MBP as usual and monitor the charging. If you still feel it's not charging as it normally would, then reset the SMC again but with the following steps instead:

  1. Shut down your MBP
  2. Press and hold the right shift key and the left option and control keys for 7 seconds before then also pressing and holding the power button down for another 7 seconds (i.e. the keys will end up being held down for 14 seconds, the power button for 7 seconds)
  3. Let go of all three keys and the power button
  4. Wait 5 seconds
  5. Power up your MBP again
  • Please note I've just added more to my answer in case the initial reset of the NVRAM and SMC doesn't work. All the best! – Monomeeth Dec 14 '18 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .