Recently switched from Chrome to Firefox Quantum and noticed that images from *.googleusercontent.com aren't loading because "The connection used to fetch the resource was not secure"

Images from lh3.googleusercontent.com not loading

If I attempt to load the image directly, Firefox gives "Unable to connect" and checking site info it shows that the "Connection is not secure"

Loading a single image also has same problem

Tried to fix the problem in Firefox by restarting in Safe-Mode and also "Refresh Firefox", unfortunately problem still exists.

Safari has the same problem (insecure connection). Everything works fine in Chrome.

Version details

  • Firefox: v65.0.1 (and previously v63.0.3)
  • Safari: v12.0.2
  • Chrome: v70.0.3538.110
  • MacOS: Mojave v10.14.2
  • Hi - great example. Now that you know two things: 1. Different browsers check security differently 2. Different browsers ignore the system lookup and just go to the address they “know” is the correct one bypassing your DNS - is there still a question or should I edit this into yours? Please feel free to take these words in yours pyko - the hosts file nailed why in my mind.
    – bmike
    Mar 9, 2019 at 14:24
  • Interesting thought. I was assuming that the hosts file would impact all browsers, though if the browsers check security differently then that sounds like a plausible explanation.
    – pyko
    Mar 10, 2019 at 0:40

1 Answer 1


On whim, decided to check my /etc/hosts file and noticed I had the following entry: googlehosted.l.googleusercontent.com

After removing it, the images now load as expected.

Interesting that Chrome still worked despite that entry..

  • Curious why Chrome worked despite the entry in /etc/hosts ...happy to give bounty to whoever explains it!
    – pyko
    Mar 9, 2019 at 6:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .