1

I like using numbers 2.2 but also have 4.3.1 installed. I would much rather use 2.2. as its been working all along and because I like the format bar which is not in 4.3.1.

I've been using "Open With" to get my files to open in 2.2, but now when I try to open in 2.2 I get a "The index.xml file is missing" error message and can only open them in 4.3.

How can I get back to 2.2?

1

Just "spitballing" here, but do you have a Time Machine backup?

If so, search it for 'index.xml'. If you find a file that resides in a Numbers 2.2-related folder, copy it to the present and put it in the same spot where you found it in the "past".

0

There's a few things you can check, but they're a little hit and miss in terms of what will work for individual users. Some of these are also troubleshooting steps to help get to the bottom of the problem (although I should state at the beginning this is quote common when you have two or more versions of Numbers installed on the same device).

Some things to try (if you haven't already):

  • Shutdown your Mac, wait about 10 minutes, reboot.
  • Check your Login Items to ensure you haven't got a Numbers document in the list. If so, remove it. (Go to Apple > System Preferences > Users & Groups > Login Items).
  • Disconnect your Mac from all networks (including the Internet), quit Numbers, and try again.
  • Boot your Mac into Safe Mode and try using Numbers. Then boot up normally and try again.
  • Have Numbers 2.2 open first before trying to open Numbers files (and ensure Numbers 4.3.1 isn't running)
  • Select a Numbers document in Finder and use the Get Info (commandI) option to see if you can select Numbers 2.2 from the Open with drop-down list. If you can, click on the Change All... button

If none of the above work, even temporarily, then you may have to just totally remove Numbers 4.3.1. However, this course of action is not one you will be able to use forever as Numbers has evolved significantly over time and version 2.2 won't keep working as you upgrade macOS etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .