I got a text message, and I want to copy an email address from message context, but iOS comes to send email app, how can I copy it?

Thanks in advance.

2 Answers 2


At least under iOS 5 you should be able to see a blue circle with a white arrow inside next to your text message; tapping on this will bring up a list of links (if there are more than one in your message), including the e-Mail address. Tapping on the e-Mail address will bring up the default "Info" page, from which you could create a new contact. More importantly, on that "Info" page you´re now able to tap-and-hold on the e-Mail address at the top, which will bring up the "Copy"-Bubble.


Revised for clarification. Use IOS's copy functionality to copy an email message. Press on the desired message (with email) and hold for a few seconds to bring up the Copy dialog. Click on the Copy dialog to copy the message (including email address). The entire message is copied. At that point, paste the message for further modification if desired (if it contains more than the email address).

Note: This worked for me in iOS 5.

  • Maybe I'm dense (likely) but if I touch a text balloon in a text message I get copy for the entire entry, not a single word or email address. What am I doing wrong? How do you select a single word in a group of words in a text message?
    – Richard
    Dec 24, 2011 at 3:32
  • 1
    Copying email address is not as simple as you said, because email addresses in message is a link to send email, please try to do it. Dec 24, 2011 at 6:15
  • @Mehdi, with iOS 5, I am indeed able to copy the email address from the text message without sending an email. Just press on the message (hold for a few seconds) until the Copy dialog appears. Tap on Copy and you'll have the email address.
    – JW8
    Dec 24, 2011 at 6:27
  • @JW01 I tried to hold for a lot of seconds, but was not different, my iOS version is 4.1, maybe it is older iOS problem, Anyway thanks for advice. Dec 24, 2011 at 6:39
  • Thanks Mehndi, works like a charm. The email messages I was testing on weren't formatted correctly so didn't work.
    – Richard
    Dec 24, 2011 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .