2

I have a Brother DCP-7040 USB connected printer on my High Sierra system that I'd like to share on my network if possible. It is using the Brother-supplied CUPS driver, which I just updated yesterday. The driver version shows up as "4.5.2" in the printer's "General" settings.

In Printers and Scanners Preferences I have the box checked beside "Share this printer on the network". In Sharing Preferences I have the boxes checked beside "Printer Sharing" and beside the specific printer, and I have "Everyone Can Print" in the "Users" box.

I have two other Macs on my network. Neither of them can see this supposedly shared printer.

I'm pretty sure I had this working under either El Capitan or Yosemite, though at that time I had a Win10 system on the network and no other Macs.

  • Are the other two Macs also connected to the same network that the first Mac is using to share the printer? – Monomeeth Dec 12 '18 at 3:50
  • can you share anything (like screen) with other Mac's – Ruskes Dec 12 '18 at 5:20
  • Do you have the firewall turned on? If so, turn it off to see if Printer Sharing starts working – Allan Dec 12 '18 at 10:03
  • All three Macs are connected to the same network. Screen sharing works fine. I'll update this comment when I have a chance to check on the firewall. Perhaps I should also turn off Little Snitch (running only on the Mac to which the USB printer is connected directly)... – g1l1t1 Dec 12 '18 at 16:51
  • Little Snitch is most likely your problem. Most people do not need it. – Marc Wilson Dec 15 '18 at 22:39
1

After Printer Sharing is enabled, follow these steps to connect to that printer from other computers on your network:

  • Click System Preferences in the Dock.
  • Click the Print & Fax icon.
  • Click the Add button (which carries a plus sign).
  • You might be prompted to add a printer automatically when the Printer Setup Utility opens. Click the Add button to begin the addition.
  • From the Browser window that opens, click the Default button on the toolbar.
  • Choose the printer.
  • Click the shared printer you want to use and then click the Add button.
  • This is actually just what I did when I set up the printer on the serving Mac. I've deleted it and added it back a couple of times too. – g1l1t1 Dec 12 '18 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .