I want to have the following setup on my MacOS machine:

  1. All audio should go to a Loopback device (call it "main"), configured as the main system audio device, so that I can use the native macOS volume controls for everything.
  2. Using the "Monitor thru -> HDMI" I'll be able to listen to it on my system
  3. Spotify audio should be instead captured
  4. Injected into a Hijack workflow
  5. Enhanced by an equalizer, peak limiter and whatnot
  6. Routed in output to the above "main" device

So that, when I see some video on Youtube I can listen the audio, and when I listen to music on Spotify I can listen enhanced audio, all controlled by the main system volume.

It doesn't look like incredible, but I just can't cause item 3 above is not working, audio is not "Hijacked", Spotify keeps sending its audio stream also to system audio, so either I hear superimposed audio tracks, or I need to route it to another virtual device losing macOS native volume control.

I know that Spotify unfortunately doesn't have a setting to force it to output to a specific audio device, but is there a way to really "Hijack" it, meaning to capture its audio AND NOT have it arrive to the default system audio device?

Curiously, Airfoil from the same Rogue Amoeba seems to be able to capture audio from an app AND prevent it from spreading to default system audio, strange that with more powerful.


This is my rather simple Hijack setup:

Hijck setup

It reads from Spotify, passes thru couple of filters, outputs to Loopback, but could as well output to HDMI or some other output. Sending it to Loopback makes it for system volume to work.

Now, since "Loopback Audio" virtual device is also my system audio device, even if I switch the switch in the image, I keep listening to the music, cause Spotify is "streaming" to both.

The ridiculous things here are many: - Obsession from apple at not controlling HDMI audio output volume, as if having to use another remote to control volume of external speakers outbalances the imperceptible quality loss of software volume adjustment .. which is there in Spotify anyway :D .. this makes me use Loopback in first place. - Lack of "Output device" setting on Spotify, there are pages and pages of rants about this on the Spotify forums, however on Linux and on Windows 10 there are system-provided per-application mappings .. which are not in MacOS .. this makes me try using Loopback and/or Hijack - Hijack not "hijacking" the audio stream, cause Spotify keeps streaming ALSO directly to main system audio .. curiously Airfoil is instead able to prevent it to stream to system audio, de-facto hijacking it better.

  • You shouldn't need Loopback to do this. Audio Hijack can do it on its own. Post a pic of your Audio MIDI setup & your Hijack Session window. & see this for some routing ideas - apple.stackexchange.com/a/203009/85275 – Tetsujin Dec 11 '18 at 7:34
  • @Tetsujin thanks for you comment, added image and bit more rants :D – Simone Gianni Dec 11 '18 at 14:30
  • I’m on my phone for the rest of the day. Will have a look tomorrow. – Tetsujin Dec 11 '18 at 15:17
  • Looking at the Hijack pic though, I’m still tempted to think it’s something in Loopback. I’ve never looked at the switch, so I’ll have to check that out. – Tetsujin Dec 11 '18 at 15:25
  • The more I look at it, the more I think you're breaking the routing in Loopback, not Hijack [the switch is a red herring & doesn't even need to be in circuit.] If you set that output to a specific device, then that's where it will go, all the time. – Tetsujin Dec 12 '18 at 8:55

You must log in to answer this question.

Browse other questions tagged .