6

Recently I started getting this really weird but annoying bug. While the app is in the Dock but not working, its icon is in good resolution. But once I open it, the icon switches to low resolution. Same thing with its icon in the app switcher (Command + Tab) view.

It only affects the Wolfram Mathematica app. I tried reinstalling the program as well as the whole Mac OS X, but it's still there, anyone know how to fix it?

I am running Mac OS X Mojave.


Before launching the app:

enter image description here


After launching the app:

enter image description here


Version of Mathematica:

enter image description here

  • 1
    Welcome to Ask Different :) It's most likely a bug with the Wolfram Mathematica app (especially if it's happening only with this app). Possibly an incorrectly supplied resource in the app bundle. Make sure you are using an up-to-date version of the app (which is 11.3.0 as of this writing). – Nimesh Neema Dec 10 '18 at 11:47
  • @NimeshNeema The thing is I've got the newest version, updating, downdating, reinstalling doesn't help at all, it thought it might be some icon cache problem (I've added screenshot with version of program in the thread). The most flustrating thing about this is it just started to be low res out of the blue. – Victor Dec 10 '18 at 14:48
  • Seems like PyCharm 2019.1 is suffering from this too – n1000 Apr 10 at 10:37
  • Judging from this comment it seems like this should be accepted answer. – n1000 Apr 10 at 10:38
2

This appears to be a bug in the app itself. It's also affecting the Wolfram app and affects not only the icon in the dock, but also the app switcher icon. I tried creating a new WolframDesktop.icns file, but the application still reverts back to the lower resolution icon on my 13" MacBook Pro. The icon renders fine on a 15" MacBook Pro. Both are running Mojave.

  • I contacted Wolfram support, but haven't heard back. – Dan Kowalczyk Jan 9 at 18:56
  • 2
    Wolfram developer here. Yes, it is a bug, and it's been resolved for the upcoming v12 release. V12 is in prerelease right now, and I expect it to be shipping probably within the next month. – John Fultz Jan 10 at 18:40
  • Thanks for confirming the bug, John. Will the fix be released to both Wolfram Desktop and Mathematica? – Dan Kowalczyk Jan 10 at 19:42
  • Yes, both products will be updated with the bug fix. – John Fultz Jan 10 at 21:13
1

Probably the first two things to check are that you've only got the one version of Wolfram Mathematica installed and that it's also the latest version.

If the problem still persists after you've double-checked the above, you can also choose to reset and restart the Dock. Note you will need to re-add any non-default icons (i.e. apps) that you've added to the Dock - so you may want to take a screenshot of your Dock as a reminder of what you had there. (Or start afresh and only add things as you actually use them).

To reset and restart the Dock, follow these steps:

  • Go to Finder
  • Press and hold the option key down
  • Now go to the Go menu
  • Select the Library option to open the User's Library folder. You can let go of the option key now.
  • Go to the Preferences folder (i.e. within the Library folder)
  • Find and move the com.apple.dock.plist file to the Trash
  • Now open Terminal (usually located in Applications > Utilities)
  • Enter this command killall -KILL Dock
  • Press enter

As mentioned previously, you will need to re-add non-default apps back to the Dock.

If this doesn't resolve the issue, it's almost certainly an isolated issue with this app and you'd be best to contact their support to raise the issue with them.

  • 1
    Unforunately it didn't work. – Victor Dec 10 '18 at 15:05
  • Thanks for letting me know. As I mentioned at the end of my answer, if this doesn't work you really need to contact them as it's almost certainly an isolated issue with this version of the app. Either they're not aware of it, or they're already working on an update. – Monomeeth Dec 10 '18 at 22:16
1

Usually the icon of an app is part of the application bundle (the directory with the „.app“ file extension). It is available in multiple sizes, e.g. 512x512, to minimize rescaling effort and to maximize display quality.

At runtime, an app can programmatically override the icon of the running process. If the app is not aware you are using a hi-dpi display, the effect you described will occur.

This problem probably will be resolved with a future update - I‘m afraid there is nothing you can do about that right now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .